Snow particles come through my buildings

I cant seem to stop the snow from coming through my buildings is there anyway to stop this?

I have tried adding collisions to the buildings meshes but that didn’t do it, i do have collisions on the particles but that just seems to kill them when they hit the floor.

They are GPU Sprites if that helps.

Yea, the collision detection is not 100% accurate. Or do they all come through the building?

There’s a training stream with this topic.

Yeah they all seem to come through the buildings :confused:

Ah so because they are GPU sprites they only collide when the object is in the video buffer (Visible), so the only way i see round this is to have seperate instances of the snow.

Or you could use distance field collision, if that’s an option for you.

You could also use cpu particles.

GPU particles are cheaper to render en masse, but require mesh distance fields to get collisions working. Also keep in mind that non-uniformly scaled meshes contributing to the distance field collision layer may not be as accurate and have “holes” in their collisions so to speak.