"Skipping dirty area creation because of empty bounds" Warning

LogNavigationDirtyArea: Warning: Skipping dirty area creation because of empty bounds
Any ideas on how to fix this LogNavitationDirtyArea Warning? I can’t find literally anything on this.

Thanks!

1 Like

Same issue here but with a BPactor with InstancedStaticMesh

LogNavigationDirtyArea: Warning: Skipping dirty area creation because of empty bounds (object: InstancedStaticMeshComponent /Game/_Maps/TestMap.TestMap:PersistentLevel.BP_Manager_2.InstancedStaticMesh)

Can’t package because I also have a crash related to this BluePrint,

if I found something I tell you here

Are you using dynamic navmesh?

The same issue here with instanced static meshes. Any idea how to solve this?

Did you guys upgrade/migrate the project from a version of the engine that you compiled yourself? (I did, and I am seeing this warning)

I use 4.26.1 and got the same errors… basically for all my custom meshes.

LogNavigationDirtyArea: Warning: Skipping dirty area creation because of empty bounds (object: StaticMeshComponent /Game/Maps/ModelTest.ModelTest:PersistentLevel.LightSphere_low_InnerSphere_low_3.StaticMeshComponent0)

Hey guys I got the error to, I think it’s to do with assets bounds and since 4.25 the bounds are set very small in the project settings, will try and update if i find a cure!

Hey guys I got the error to, I think it’s to do with assets bounds and since 4.25 the bounds are set very small in the project settings, will try and update if i find a cure!

I just solved this in my project.
While using dynamic navmesh, ensure that your mesh never reaches 0,0,0 scale. I just added a simple “Is Nearly Zero” check with a threshold of .001 or so and the error went away.

Cheers!

1 Like

Same here on 4.26.1.
Crash on level load, every time, because of this…

Seeing the same here on 4.26.1. I’ve tried adding/removing the navmesh, enabling/disabling dynamic generation, to no avail. Any pointers are welcome.

I had the same issue, I don’t use navmesh in my game so I was able to fix this with setting “world settings>world>navigation system config == NullNavSysConfig”

2 Likes

Hello,

How ? Where do you do this check ? I’m using a dynamic navmesh with invokers and my foliage gives me this error all the time.

I checked my foliage components bounds at start by making them print their bounds. Sometimes, It’s 0. I don’t understand why.

Thanks, this is what I was looking for. I’m not using navmesh either for mine.

This fixed it for me too (we don’t use nav mesh either)

This is not “fixing”. This is avoiding. Without navmesh, how can you move AIs efficiently on the ground ?

What’s Dynamic Mesh and how I can reduce its size? Do you mean the nav mesh bounds volume or nav mesh modifiers or something in project settings?

Reduce the size of your Dynamic Mesh, and this issue will vanish.

You have a few options, select the Recast Nav Mesh and set it to static then test. In my case the issue was a procedural landscape generation tool that I was using to procedurally generate the trees. I am doing so and the error was happing on the Dedicated Server. I stopped the error on server by calling isdedicatedserver function and adding a branch that made it not do it on the server. Only the client is going to see the landscape anyway. You have your Nav Mesh set to dynamically alter as things happen on the map, that is why this issue is popping up at all. That is needed if you are level streaming and have AI. I am not altogether sure why yours may be doing this, but hopefully this will help you better understand the issue.

Does any of you have turned off the sublevel wich is giving the errors. My dirty area error seems to be appearing when a sublevel is set to not visible in the levels panel.

Anyway this doesnt really fix anything, the warnings just does not appear but I want to see the output log clean either having a sublevel visibility set to visible or not.