Download

Sketchup Unreal Engine

Hello every one ! :slight_smile:

I have a big problem : 5a9663d7a40853e1383117a984ed1b8f421dbc24.jpeg

I created this lamp on sketchup and I exported it to Unreal Engine with Centimeters Units. Not overlapping UVS
I put another material to see the problem : We see the faces and it is not smooth :confused:

How can I solve this ?

Thanks

Are you using sketchup make or pro?

Hello, I’m using Sketchup 2015 Pro

Hi,

you use Thrupaint or SketchUV on Sektchup for your mapping ? for me, its works well

I dont use any tool for mapping. I think the problem here is smoothing groups. How can I export smoothing groups from Sketchup ?

Are you assigning a material to the object within Sketchup before you export it?

Also, I don’t know how smoothing groups work for FBX export in sketchup, I use make which doesn’t support it. You could try loading your FBX in Maya/Max, and exporting it again with smoothing groups to see if that’s the issue.

It looks like your material assignment (UV’s) aren’t wrapping “cylindrically” for lack of a better term. Here’s a tutorial on how to apply materials to cylindrical objects in sketchup properly. Sorry about all the posts.

Cool ! Thanks I’m gonna trying your last answer !

So, I tried your method and it looks working ! http://image.noelshack.com/fichiers/2015/33/1439415097-lamp-soft-problem.png. We just see a little bit the faces but I tried another lamp for ceilling and we see nothing ! http://image.noelshack.com/fichiers/2015/33/1439415184-lamp-no-problem.png. I also set the lightmap to 256 and I unticked “Compute Normals” and “Compute Tangents”. Then, I ticked ticked the 3 first options : http://image.noelshack.com/fichiers/2015/33/1439415321-two-sided.png.

Thanks

When you’re applying your material in Sketchup, what is your texture scale? I think it defaults to 0.01 x 0.01 for me (away from my workstation atm so I can’t check) but try upping those values in Sketchup before you export your FBX and see how it looks. It looks like your image isn’t scaled properly, like it’s only wrapping a small, zoomed in portion of your whole texture, if that makes sense.