Skeletal mesh not showing on Android Device


I have the following situation.
It is my first time using Unreal Engine and I wanted to try to load a character and make a quick project to see how it looks in game.
I imported a skeletal mesh with no animations and using the third person template launched it on my Android device but in does not show, it is the level because I can collide with it.
If I import it as a normal mesh and place it is shows.
I also tried importing a Daz3D character and I have the same situation.

Thank you

The mesh is a human character so it doesn’t exceed the vertices and bone limits. I read in the forums and the answer hub that more people had the same problem after upgrading from version 4.2 to 4.21 and call it a bug. I could not find a solution searching the net

I don’t know how much matters but the mesh has a lot of morph targets


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


i have the same problem with this version ( 4,21) too . in 4.20 the skeletal mesh was shown fine

Yup exact same issue. Skeletal mesh won’t display on Android after updating to 4.22 Worked fine on 4.20.

Hi guys ,
There seems to be 2 solutions, which I’ve tested, that work:

  1. Unchecking ‘Support OpenGL ES2’ and check ‘Support OpenGL ES3.1’ - under Project Settings > Android > Build
    This would support less android devices however: OpenGL ES 3.1 - This API specification is supported by Android 5.0 (API level 21) and higher.

  2. Removing Vertex Bones - More than 4 Vertex bones on a Character will create problems. This can be done directly in Unreal through the ‘Skeletal Mesh Reduction Tool’ - see also here

See forum threads:

Link1 and Link2


1 Like