Announcement

Collapse
No announcement yet.

Character is missing on Mobile Device

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Character is missing on Mobile Device

    Hey,
    I have a problem, where I cant find a solution for.
    Yesterday i discovered there is an Application in Adobe CC which is called Fuse.
    I created a Character, sent it to Mixamo and downloaded Mesh and Animations.
    In the Editor everything is ok, but when I launch the game on my Android Device ( Galaxy S8+) the character does not show up. Movement and all are working but the Mesh is just not showing up.

    A few Days ago I tried it with a Premade Mixamo Character (AJ) and it worked fine.

    My Character has around 18k polys and 25 bones.
    I have read the maximum vertices for mobile games are 65k and 75bones.
    This should not be the problem.. and I couldnt find a way to create a low poly character with fuse.

    When I import the skeletal Mesh, this warnings come up but i cant do anything with this warnings.


    I hope someone can help me.

    #2
    faced the same problem. Mesh - character is not visible. And some textures are not displayed, there is no half of the sky in the game. At the same time, the sky is standard. Importing a character from mixamo. When transferring it to third-party programs and after saving in FBX format - it does not help make the character visible

    Comment


      #3
      I would try pasting a very simple unlit material on the character to make sure it's showing and not just some material problem

      Also in the gamemode did you set it to use the character as default?
      Headgear - VR/AR solutions

      Comment


        #4
        I have the same issue with premade mixamo characters. Only 1 out of 4 works fine. Does anyone have a solution on that?

        Comment


          #5
          In case you still facing the same problems. In my case i just had to uncheck Support OpenGL ES2 and check Support OpenGL ES3.1.
          You can find this under Project Settings > Android > Build.
          I hope I could help you.

          Originally posted by aussieburger View Post
          I would try pasting a very simple unlit material on the character to make sure it's showing and not just some material problem

          Also in the gamemode did you set it to use the character as default?
          It was a bone problem. Somewhere in a forum I've read that something changed in the newer versions in Unreal Engine and you need to enable ES3.1 When you have more then 4 Vertex bones on a Character.
          Last edited by AnGaraa; 01-23-2019, 02:43 PM.

          Comment


            #6
            solution is just export your skmesh in 3d program. And change the max bones effect to 4 . In 3ds max select your mesh in skin modifier . In advance perameters. Change the bones affect limit to 4. Then again export your mesh to ue4.

            Comment


              #7
              You can also remove all bones that are a child of more important bone. as an example This lady had many hair bones I will not need in mobile or HTML5
              Right Click on parent bone, remove all children, can do it for different LODs and set mobile to use that LOD by default

              Comment

              Working...
              X