Download

Sick and tired of UE4 having its own mind - suddenly broken lightmaps

I’ve been working on my project since UE 4.9 (mostly evenings, sometimes weekends). Yesterday I decided to rebuild lighting (UE 4.12.5; re-built lighting several times using this current version). After I did it, lightmaps became completely broken:

ue4_broken_lighting.png
Full: https://s32.postimg.org/ezzm5t2yr/ue4_broken_lighting.png

This is how it used to look like (from 4.11.2 as I don’t think I ever took “aerial” screenshots in 4.12.x):
ue4_terrain_lightmaps.png
Full: https://s33.postimg.org/98p3lt6m5/ue4_terrain_lightmaps.png

I did not change anything, it just happened out of the blue. I tried clearing Intermediate/Saved/DerivedCache, clearing old lightmaps, changing lightmaps resolutions, lightmaps atlas resolution - nothing work. My project is now f#$ked.

Has anyone experienced the same kind of issue ?

If so, how did you fix it ?

Thanks beforehand

I cloned project, but still same issue. Will try migrating assets, but something tells me the problem won’t be resolved :confused:

You can try 2 things:

1 - Check whether you have done any changes to BaseLightMass.ini in 4.9. If so, you need to do some changes to the settings in 4.12(Same settings may not give exact results)
2 - Check which Light Build Quality you are using. If it’s Production, just change it to High and try once(read in some forum post about a peculiar lighting issue in 4.12 for Production setting, may be the post was from Koola)

I never made any changes to that .ini file :eek:

Light Build Quality settings have no effect at all - whether it’s a preview or production quality, the outcome is exactly the same as seen on the pic above.

At this point I am sure I did rebuild lighting using 4.12.4 but I am not 100% sure I rebuilt it with 4.12.5 (I think I did, but I could be mixing it up with 4.12.4).

It feels like people either use older versions, or use newer with real-time shadows only. Just wondering whether it’s broken specifically for my project or if other people have issues with lightmaps in 4.12.5, so that it could be filed as bug report and fixed in 4.12.6

[MENTION=8]Alexander Paschall[/MENTION] :

Could you please poke someone who works on Lightmaps/Lightmass at Epic about this issue ?

Hi Motorsep,

Can you post this on the AnswerHub and include detailed steps or any known steps to reproduce this issue?

If you can reproduce outside of your own project this would be helpful at troubleshooting as well. Also include any previous screenshots for comparison images, because it’s not easy to just look at your images for what you have now vs what it was like, even though there does appear to be some artifacting.

Some things you can try though.

  • Delete/move temporily the intermediate folder from your project and rebuild the lighting.
  • Make sure the landscape/ground mesh has a good lightmap resolution set for it.
  • Try switching to Force No Precomputed Lighting and build to dump all static lighting from the level and then renable and rebuild the lighting.

Sure thing, I’ll do that if I have issues with new project with migrated assets from broken project.

Added screenshot with previous look in OP. Note that shadows aren’t splotchy or jagged.

Tried, no luck.

I have 256 resolution for lightmaps and 1024 fro atlas. Setting resolution to 1024 only yields sharper shadows. They are still splotchy and jagged (basically imagine that what you see on my screenshot isn’t blurry, but sharper - still blocky)

Did that too - switched to Force No Precomputed Lighting, saved, closed Editor, re-opened, reloaded project and made sure ligthmaps were purged (not present in World settings tab under Lightmass). Switched off Force No Precomputed Lighting and re-built lighting in Production quality. Still got the same exact look as in the screenshot in OP.

Hmm not sure what you meant by “…cloned the project”.
Though my client recently had some issues with light maps. The solution funny enough was to create to create a whole new project in 4.12.5 and then migrate the different bits and pieces over and rebuild lighting. Then the misalignment of the light map and black blotches were gone and it worked as expected. :slight_smile:

[MENTION=4894]Tim Hobson[/MENTION]:

So, I migrated all assets into a new scratch project and ugly blocky lightmaps are gone now. I wish I didn’t have to waste time on these tricks :confused:

Which is totally unacceptable.

seen issues with static meshes recently even with plain materials with lighting

also lightmaps reverting after lighting builds so something weird is happening for sure.

couldn’t really reproduce any instances of these occurring because it seems to be sporatic.

Engines are always going to have bugs. Hundreds are created and fixed with every update. Unfortunately anyone that works with real time engines are going to have to get used to quirks, work arounds, and stuff breaking.

If you are able to reproduce an issue and document it, Epic will fix it.

I constantly test issues in clean projects to diagnose problems.

the issues I stated above were in a clean project

and also tried in another updated one as well, still sporatic behavior.

adding &/or migrating a normal static mesh then using alt on the x,y,z handle to duplicate results in the originally placed static mesh showing unlit 90% of the time

edit:
(simple examples - straightforward migration & importing)
(haven’t looked for work-a-rounds or in-depth solutions)

https://drive.google.com/uc?export=download&id=0BzKnAtkCk9VwaWdJODBESFM2dDA

https://drive.google.com/uc?export=download&id=0BzKnAtkCk9VweG1lMEkzcmo4ODA

hope these images post - forum giving me a fit on uploading

Absolutely, except lightmappers were around for like ever and breaking out of the blue, forcing devs to migrate stuff to a new project, isn’t something that should happen with lightmaps baking tool.
@ayretek: Do you have lightmaps UV on those meshes or do you let UE4 to generate lightmap UVs ? I found that if I let UE4 generate UV maps, I get similar issues sometimes. If I import meshes with UV map for lightmaps, I don’t have such issues.
[MENTION=4894]Tim Hobson[/MENTION]: I can share my broken project via PM with you if it will help determining how lightmaps ended up broken and why they are not fixable in the project.

this static mesh was done a while back so they might have been generated by UE Editor but even if they were, shouldn’t they work? isn’t that the purpose?

& not knowledgeable about lightmapping. But I did have issues, in project before this one, with trying to overriding the lightmaps then they reset when building.

IIRC You need to hit ‘Build’ after hitting Force No Precomputed Lighting. Lightmaps aren’t purged until you try to run lightmass again.

That’s kinda obvious :wink:

It’s just that you didn’t say you’d done that, it looks like you forgot to hit build (or didn’t mention it).

like your desert scene btw

one obvious addition and first place to look btw would be the added static meshes - the rocks

Well, I didn’t mention it because it’s implied :slight_smile: