Show Mouse Cursor doesn't work in cooked build?

Hey folks, I’m trying to export my small game, and have the default level set to be the menu level, which has this level blueprint:

The stop movement bit is part of my testing to fix the issue and will be removed shortly…
Anyway, when I open the level in the editor (play in new window) it works perfectly, mouse cursor shows up and menu works fine, but in my cooked and exported Windows build, for some reason it doesn’t work. The mouse cursor won’t show up and the player is able to move around, shoot and such which isn’t possible in the editor version. What’s wrong here and how can I fix it? Please help!

Quick note: If I alt+tab out of the game, I’m able to use the menu fine, it’s just the initial launch that won’t show the cursor or stop player movement

Hi Invisible,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps are you taking to recreate this on your end?
  • Is it a shipping or development build?

I haven’t tried it in a new project yet as I ended up doing a workaround.

It’s a shipping build, tried it on different PCs as well.

What was the workaround you used? Is this working for you now?

Hi Invisible,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.