Shadows make everything black including the player?

Hi there! I am brand new to Unreal Engine and I’ve played around for a couple of days. For some reason, all of a sudden the shadows turn black and when the player is standing in the shadow then the player is also completely black. It’s not like this from the start but then when I least expect it, it happens even though I haven’t made any changes. Is this because my computer suck or something else? I get two warnings on the screen. “Lightning needs to be rebuilt” and “Reflection captures need to be rebuilt”.

Thanks in advance, Tommy

First of all, you need to decide if you want moving-type lighting or built-in type lighting. If you want moving type, you should go to your light source and select the “movable” option (it should be right under the scaling).

If you just want to leave the lighting as it is for now, then you should probably build your lighting to see if that makes the shadowing go away. Go to the viewport toolbar and select the “build” option.

If that doesn’t work, then you can try adding a skylight to soften the shadows and then build again.

Well, I’d try rebuilding the light.

Do you have static or dynamic directional light and skylight?

If it’s outdoor FPS, I’d plump for dynamic, would probably save you a lot of hassle.

Another hint, if other (mentioned above) measures don’t give you the result you’re aiming for: Too intense ambient occlusion can make shadows look pitch black. So if you’re using “store bought” assets, try opening up the material instances and see if there is a “setting” for ambient occlusion, if not, open up the material and check there. For a simple test you can just remove the ambient occlusion all together, just to see if it’s the main cause of your issue.