Shadows are weird after udpating

Hey community,

We updated our game from UE4 4.7.6 to 4.8.3 because we want the new features (we’ll update the version gradually to avoid big errors).

But now all the shadows look weird. When we move a light source, everything looks normal but we get the message that the lightning needs to be built. After building the light, everything looks like crap again.

Can you help us?

Ok, We’ve found a solution. We increased the light map resolution of the meshes. But there is still one question: Why didn’t we have the problem in version 4.7.6?

After increasing the lightmap resolution of the objects to 1024 - 4096, the game takes up all our disk space and we’re not able to build the light. Please help…

from what i can see all of the objects in your scene should have lightmaps in the 32 - 128 pixel range. the lightmap size is not your problem.

as for what your specific issue is, idk. could be a light issue, a lightmap UV issue, a project setting issue, or something else. you could try doing a partial rebuild of the scene in a new level and/or project and see if you get the same result.


Too few information! :S
Of course when you move a light it will switch to dynamic lighting and it will look “nice” and after the bake you get the static lighting which you’re after if I understand you…
In your scene you shouldn’t go higher with lightmap resolutions than 1024!! And that’s for the floor! The walls should be ok with 512… these are the TOP settings!! If you’re after lower quality you can set them lower!!
What are your light/world settings?