Shadowing artifacts on landscape after baking lights


I get these weird black aliased lines in places where meshes cross the terrain. The problem is present only with baked lighting, on dynamic everything works like it’s supposed to.

I use a stationary directional light. Skylight is also present in the scene, and it’s set to stationary as well. I’ve figured this might be a resolution problem, so I’ve tried to gradually increase static lighting resolution on my landscape. That didn’t seem to make any difference. I’ve upped the parameter to as much as 10, but the results are mostly the same as they had been with the resolution set to 1.

I’ve also tried tweaking other lightmass parameters - on the landscape actor, the lights, meshes and the lightmass itself. All to no luck.

It may be worth noting that I don’t get this problem when the stones and landscape receive direct light. (second screenshot)

What am I missing here?

Any help would be greatly appreciated.


The result looks similar to AO mapd although it’s obviously produced differently. It doesnt look like there any settings to increase baking precision. It does look like it could be a resolution issue but you appear to have tried that. If you havemt already you could try shifting the mesh slightly and see if that changes the results. I ha enter used landscapes much so I don’t know how light maps for them are setup. Personally, I suspect it’s mostly and engine limitation and wouldn’t worry about it unless it’s happening in a key spot.

Hey! Thanks for your reply!

It’s definitely not AO, since there are no artifacts in the AO buffer. I’ve tried to move the mesh around a bit, and sadly it didn’t help.

I think I’ve traced the issue down to how the skylight works. If i set it to moveable or static, the problem still persists, but the artifact is much less noticeable. Guess I’ll have to dive into the documentation again to gain a better understanding of how skylights work.

Move able and static both bake lightmaps for static objects so I would expect the same results. Definitely something to do with the baking.

Well, it’s not the skylight, since I’ve disabled it completely and the issue is still there.

probably the bounce light on the directional.

May be the terrain’s lightmap UV has error. Check your terrain’s lightmap UV, don’t let it has any overlapping.

Hi. I use ue4 landscape actor, not a custom terrain, so I don’t have any access to its lightmap. Apart from controlling its resolution. Or do I?

not that i know of.

I have just found out what this issue had been. My landscape material uses a slope-based mask, a triplanar projection and displacement. The black lines were a result of displacement map elevating the landscape and thus interfering with the lightmaps for the terrain. (At least i guess so). Anyway to get rid of this I had to turn off displacement.

Hope this helps, if someone faces a similar problem.