Shadow Distance

Hello, I have a problem with the shadows. From so close everything is fine but from a bit away the shadow quality became very bad and light leaks appear on the meshes. Here are two images of the shadow deterioration.



Even further away, more worse.

Any idea how to set the shadow quality to be the same from far as from close?

Hi! Is this a dynamic object? If so, it looks like Cascade Shadow settings need some tinkering with, have a look at this documentation. This might help as well.
Let me know if works out :slight_smile:

Hello! On the image is a static mesh but the results are the same with the movable mesh too. My Directional Light is movable and I changed only these values:

  • Shadow Slope Bias 0,3
  • Shadow Filter Sharpen 1
  • Num Dynamic Shadow Cascades 4
  • Distribution Exponent 4
    The other values are defaults. On the meshes, the Far Shadow is enabled. I saw Far Shadow settings under the Cascaded Shadow Maps section but whatever I set nothing changed.

I read these documentations, but didn’t help to solve my problem.

Aw, sorry about that. Let’s try these console commands instead then, they relate to shadowing relative to the camera rather than to the light:
r.Shadow.RadiusThreshold (Default 0.03): lowering this increases visibility of shadows when camera is far away,
r.Shadow.MinResolution (Default 32): lowering increases shadow visibility.
r.Shadow.FadeResolution (Default 64): lowering this value keeps shadows from fading over distance.
There’s also the Far Shadows setting in your directional light, increasing this may also keep shadows from switching down like yours.
Hope this helps :slight_smile:

I tried all of these commands but the shadow resolution changers do make nothing. The radius threshold command is worked (at least did something, namely set the shadow’s visibility distance). But the problem still persists and it looks like if I reduce the Num Dynamic Shadow Cascades’s value when I’m going away. Looks like from so close the value is 4 a bit far is 3 and so on to one or zero (there aren’t visible difference between the 0 and the 1 value).

This is strange… Last thing I can think of are your engine scalability settings, are they set to “Epic”?

All scalability settings are on Epic.

I think I need settings where I can set separately every single Num Dynamic Shadow Cascades’s value just like the when you set the LODs values for the mesh. I miss these settings, but may there are settings just I don’t found yet.