shadow display when selecting object


I’ve got a trouble in displaying correctly dynamic shadows with a translucent object :

when the object is selected the shadow looks good :

when i deselect the object the shadow appears with no volumetric effect :

Light is dynamic, shadows are too, the glass material is set to Lit volumetric directional, and the object has Volumetric Translucent Shadows option on.

Also when compiling, only the “bad” shadow appears.
Any idea ?
Thanks a lot !

Just found by myself : had to check on “two sided” option in the glass material.