Shadow detail distance too low?

I hate to be that guy asking about shadow issues but i feel like i have misconfigured something and ive just spent hours trying to fix this, My shadows seem courpted / or blotch but render good really close to the camera. Im having UE4 Generate the Lightmap.

Bump, I changed some settings with the Cascade Shadow options on my main light source after rebuilding the lighting.
Issue is still there on many of my mesh’s. I’m beginning to think this is my light map resolution on my Mesh’s or that my Shadow map is too small.

I do not think this is a case of improper Light map UV.

One of the things I learned was that my Grid in my UV texture editor in Maya was way off causing Artifacts previously but since then I have fixed this.

Has anyone experienced this or have a workaround? I’m sure its something as simple as a check box or a wrong value.

Many of my Models and BSP Brushes are Blotchy on the shadows


Do you mean the two little rectangle lights after the bake /that it’s not the correct shape?/?
…or the second image where the lines re not straight?

not the correct shape, the Shadow is throwing the triangle bits. It should be clean lined like the second image. I disabled Cascade Shadow’s so its just blotchy and incorrect shape.

I was following this guide here A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

I’m going to try Upping up my Shadow res / Light map res on my model, Light and terrain.

Yes! The lightmap resolution is too low on the receiver side (floor)!
You will get the correct light/shadow shape if it’ll have enough resolution!
…BSPs used to work the opposite way: you had to lower the amount…

I’m not home right now, I will have to check out the Light map Resolution and scale it higher to see if this is my issue I am at work Eager to Fix this!

As far as the BSP I believe its still true Lower = Higher Quality.
But not for Models.
I mainly use the BSP for Blocking out General shapes till I can mesh in the level.

I can confirm this was my issue, I instead had set the Min Light map resolution instead of the actual light map resolution!

I’m currently running around fixing all my assets Thank you for Guiding me in there!

Good luck! :slight_smile: