Shadow Casting Problem

Iam new in unreal engine and i have downloaded unreal engine 4.10
but i have problem in shadow casting especially dynamic shadow casting
when i make any movable object or any kind of BSP like wall there is no shadows in the objects
how i can solve this problem
Thank You

and here is the problem and my setting

Set “Dynamic Shadow Distance StationaryLight” to some value like 20,000 instead of 0. Make sure your light is set to ‘Stationary’ or ‘Movable’. If you have other objects in your scene which are set to static, such as BSP or level geometry, make sure to click ‘Build’ to have the static lighting baked into them.

You could also convert your bsp to static mesh, but that might not be very optional.