Shadow bandings when baking stationary light

I was using very high quality and very high res lightmap to bake the light.

the shadows is ok at the corner, but comes out bandings at the end of the shadow.

I thought it was because the lightmap is 8 bit,and lacks of information when the lightness is very similar.

Is it possible to bake a 16bit lightmap or using the dither technique to solve this problem? Any other ideas are welcome

Do you use compressed lightmaps by any chance?

I disabled the compress, and the settings are very high

Any post processing?
…to be honest it’s not just the dithering… if you look at the corner the lighting is totally off!
Any tweaked lights in your scene?
I think you can change to 16 bit by selecting “Use full precision UVs” in the object’s properties window. But I think it won’t solve this problem…

Just an idea, you tried increasing the static lighting level to around 5? Not sure how that will overall impact performance though.