Shaders not compiling after I compiled 20,000+ shaders at a time

I had this problem on UE 4.21 that when I compiled shaders above 20,000 or so (tried opening all the demo maps from the assets to compile the shaders like opening demo map for Paragon and then while the shaders of Paragon are compiling, opening the map of Ice Lands and the shaders would increase) to make it less annoying to open anything within the level design, my UE would hang and won’t do anything. Its CPU usage dropped to 5-6% instead of normal 60-70% when compiling shaders and UE won’t do anything and then I had to force close UE after 2-3 days of it being stuck. I did everything but didn’t help. I even uninstalled all the assets, UE, Epic launcher and data from %AppData% and reinstalled everything but again, when I opened something in UE, it would keep compiling shaders without actually compiling even one shader. It would say compiling shaders for even 1-2 days but wouldn’t compile a single shader. Then I eventually had to reset my Windows, delete everything and start from scratch. I then installed UE 4.22 and this time, I tried to compile all the shaders in the project at once by opening every map, material and asset one by one again. And now again, my UE was stuck and I had to force close it using task manager after 2 days of it being stuck. And it is again not compiling any shaders and is stuck on the same number for days… Please HELP! Thank you in advance and sorry for bad English.