Shadercompiler is absurdly slow

I have been using UE4 for ages now, and ended up upgrading my system due to the severe slowness of the ShaderCompiler. For the record it is not my PC: I have a Ryzen 1700 and a GTX 1070 and 32gb of RAM so I’m pretty sure it’s fine.

I also see that this exact same question has been asked many, many times on Google and I have not seen a single answer from any UE4 employee about this issue, or any solution.

Please fix this or I will be uninstalling this engine and changing to one that works properly…

When exactly are you seeing the problem? Is it when you’re creating / editing a shader or are you finding that the engine is constantly trying to compile all the shaders? I can’t offer much help as I’m not 100% certain on the shader compilation steps, but I can tell you that projects I’ve worked on do not see a huge problem. If I wipe all the cache, it may take a little while to recompile everything, but that’s to be expected. If I’m editing a shader then there might be a couple of minor delays but they rarely disrupt the workflow (you can turn off live previews etc to help if needed).

Is it the shaders themselves that are overly complex?

Well absurdly slow is very relative, can you tell how long it is taking for a small color change to compile?

whoops… will convert this to a comment then, sorry about that

A GPU based Lightmass is coming very soon, possibly 4.20, here’s the thread detailing it:

It was made by Luoshuang, who just moved to Cary, North Carolina (where Epic is located) so he is either currently, or soon to be employed or under contract by Epic.

You can use it with 4.19 too, most people are reporting a 10x or greater build time reduction using his system, feel free to download it and give it a try, there is a link to download it in the first post.

Hope that helps you!

I’m not discussing lightmasss, I’m discussing shaders. Thanks though.

I mean that I sometimes need to recompile all of the shaders due to the fact that I tend to edit them a lot. The typical time for, example, the Elemental Demo is over an hour. It’s ridiculous. I am not the only one with this problem, check Google. I haven’t seen a single resolution to this problem thus far.

You can try to set the priority of “ShaderCompileWorker” to high from task manager(Never ever set it to realtime, just a reminder). See if that makes an impact on your compile time.

I have the same problem and im not able to change the priority in the task manager, because the process just gets replaced by a new one with the same (lower as normal) priority (Or it can’t even be changed). Can i edit the priority permanently somewhere?