Shader compiler crash on "shadermagic cleanup"

I’m getting a crash after upgrading to 4.13, then attempting to modify the landscape that has been persistant since 4.12 or earlier. Specifically, I’m getting this error message on crash: Assertion failed: Canary != FShader::ShaderMagic_CleaningUp [File:D:\Build++UE4+Release-4.13+Compile\Sync\Engine\Source\Runtime\ShaderCore\Private\Shader.cpp] [Line: 440] &nl;&nl;

Link to the crash log:

I’ve tried this on two separate computers with the same result. Does anyone have any idea what’s going on?

Hello Sentura,

It sounds like you could have a corrupted or dirtied asset or file. Can you reproduce this issue in a new blank project using a simple landscape actor?

If not, then this is definitely a project specific issue and we will need some more information. Can you provide me with your callstack?

Thank you,

I tried your approach with a new project and it worked fine with landscape and material - after a successful recompile of the master material. It made me think that recompiling the master material would solve something - and it did. The landscape had some “geometry” issues corrected from 4.12 to 4.13 (I was prompted to correct them), I guess it could have had something to do with that?

For now I consider the issue resolved. I can still provide the callstack if necessary.

I’m having the same exact issue could you shed some light on how you resolved this? My project opened fine the first time I opened it on 4.13 and it compiled shaders but when I opened it a second time it crashed while compiling shaders with the same error and I cannot open my project for more than a few seconds into compiling. What was kind of weird is it started compiling shaders when I opened the project the second time even though I had just compiled saved and tested the project to see if things were working okay after the switch from 12.5 to 13.0.

In my case the shaders didn’t start compiling until I opened the map file. My conjecture is it has something to do with the rendering, and should thus not cause any crashes if you don’t open a map (or any other place where the material is being rendered).

Hi there

I having an issue with my project I updated from 4.12 to 4.13 and the shader counter is going down to 530 and then crashing. It loaded fine the first and now it wont stay open long enough



and when i try and load the 4.12 version is crashing instantly

Can you please post a new AnswerHub question for your issue as this one was resolved by the user. The issue you are reporting might be related, but it doesn’t sound like that is the case, so for tracking purposes we request you create a new post and provide a link to your new post in your response to this comment.

Thank you,