Download

Setting up a tiled landscape material with Layerblending

Hi,

I’ve created a tiled Landscape in World Machine. The Import works fine for the heightmaps.
I would like to use the texturing capabilities of World Machine aswell, but so far I could not manage to get anything other than the heightmaps to work.

I’ve set up the most basic of materials.
1.JPG

I filled out all the Information on the import dialog.
5.JPG

The landscape remains black everytime.

The blendlayers are correctly assigned - I can paint on them and the color shows up. So the problem seems to be rooted within the imported Image.

I created the Weightmaps in Worldmap. This is my Setup.

I followed the tile-resolution recommondations from here: Landscape Technical Guide | Unreal Engine Documentation

This is what I put out. So far I have tried png in 8 & 16 bit, RAW aswell as bitmap outputs.

I’ve already made the ‘compromise’ to work with the slope-selection filter, since it seems to work in this tutorial: How To Make A Multi-Biome Open World Map - Unreal Engine 4 [Part 1] - YouTube
but no success. In an ideal world i would like to output a simple black and whit mask from the landscape that I prepared previously, or even grab the direct colors out of WM - but I dont see how.

I’ve searched the web, but most solutions seem to be focused on non-tiled landscapes that seem to behave entirely differeint when it comes to texturing.

Has anyone had this Problem before?

Kind regards

… so. On the import panel. Are you clicking the button and selecting the 64 images that belong to the appropriate layer?
because what you have says 2.
2 is most definitely senot 64, which is what world machine screen shot shows.

The tiles should be black/white PNGs that contain the layer info.
Usually for me, layer one is a whole white image. Layer 2 and all other layers are black. (Because i don’t use world machine, which maybe i should, ill grant you that).

Another tip. Close down the world composition mini map before import, it tends to have you run out of video memory when it is open (it did in .24 anyway).

Yet another tip. do not delete the landscape or the gizmo from the persistent. You can modify the values on the landscape and the changes propagate to the tiles when you load them/save them.

Hello MostHost,

Thank you for your reply!
Yes, i have only selected 2 of each tile for the screenshots I made for this thread - As you can imagine it takes quite some time to import 64*3 Tiles.
I have tried to import all 64 Tiles before though, and the problems were the same as described above.
I have made sure to select the heightmap tiles as well a set of grayscale tiles for each Layer.

I don’t know, if there is anything I can do wrong whith the images. Here are Examples (If that even helps) https://drive.google.com/drive/folders/1miaEscci7hJj_P938TSI1HUWLYdvzNiz?usp=sharing I have included the Heightmap for tile x0_y0, two raw-files, which are basically inverted versions of each other - thats what came out of the WM-Slope Mask and a png of one of the Masks I originally wanted to use. (note: I just rendered them out as an example in smaller resolution, I have tried it with the same res as the Heightmap aswell though.)

When you say Layer one you mean in the ‘import tiled Landscape’ Dialog?
How do you see which color your Layer has?
So every tile in your Layer 1 Weightmap is pure white?

And thanks for your tips aswell!

Regards

I mean what your import dialog has labled as Layer1.
in my case the specific name is AutoMaterial, but the poithis the same and would apply to any layer in any sequence.

all the importer does is apply a mask to the specific tile in order for the colors to be visible/visualized correctly.

you can always open the individual tile - not the world comp level, turn from lit to base color so you can see, and attempt to import a new “splat map” (I suppose thats what people call them?) Or paint layer like you would for individual levels.

Thats actually a great way for you to test what your file does.

Another thing to keep in mind.
ONE of the layers should always be full white imo, at first. Because no paint layer to use means no color.

so in my setup I have a layer for the auto material that is always filled. And then you have several layers for the other stuff; marshland, rocks, pebbles, sand, etc. (Limited to 4 layers per tile).

When you paint over the first layer in engine, the engine does the blending of the files for you, so that you have valid information on all layers.

When you import images, you could potentially end up with bad information in the layers.

If you were to place/compose layer1 over layer2 in a graphic program you should end up with a completely white image - in theory.

I’ll try and review your files, but I doubt that they are “wrong” if they just came out from world machine. I think the error is perceived usage more so than bad files…

Oh my God I could kiss you.

My main problem was actually not having the first layer empty or white. I re-exported some stuff and adjusted my material and got a result for the first time!
My old Images still seem to be broken for whatever reason, but at least I have a foot in the door now.
From here I’ll be able to figure the rest out!
Now I’ll work out what exactly went wrong and I’ll experiment a little so I can report back here for future reference if anyone else ever faces such problems :slight_smile:

Finally I can start making my Texture :smiley:

Regards

Alright, it will need a bit longer to gather everything, but for now a couple of insights I got along the way:

  1. I definitely recommend using .r16 for the heightmaps, but other formats work too. I tried png, jpg, and raw variants and that did not seem to affect functionality. The format of splat and weight maps also does not matter in terms of functionality.
  2. Make sure not to have forbidden symbols in your tilenames. This includes spaces - which are part of the standard naming convention of worldmachine. Change this beforehand in your output node, or you will have to rename the files afterward. If you don’t do this, the “Levels” window will only show one tile. If you try to load that tile UE will crash.
  3. You might think, your splat and weight maps can have a different resolution than your heightmap. That’s reasonable to assume in your 3D workspace, but in UE it only returns a pitch-black Material.
  4. Choose your tile sizes from this list of recommendations: Landscape Technical Guide | Unreal Engine Documentation this will make the transition between your world-editor and UE much less painful.
  5. The Problem of this thread: Leave your first layer empty. I could get it to work by importing nothing as the first Layer of weight tiles, or pure white images. The latter achieved better results.
    If you input anything in there it messes with the material in ways I have yet to figure out, but if I leave it blank the other layers do not seem to be affected. (more on that once I know more.)
  6. Your weight maps can be exported by either using Worldmachines bitmap or height output. Both work. They can overlap. Though there is a limit of layers you can have layered on top of each other at the same time. Once this limit is violated the tile will return black.

Hope that helps anyone. I feel like I managed to fall for every possible mistake one could make along the journey. But at least that means I understand a lot more about landscapes now ^^

Regards

1 Like