4.26, issues I'm having, Yes I'm freakin new and frustrated

First I’ve spent HOURS doing learning tutorials. More HOURS implementing the tutorial lessons. Read HOURS of documentation regarding the engine, fixes, blueprints, coding, rendering, GPU lightmass, UE recommended requirements (system, export/import, plugins, procedures, limitations, tiling…etc…

My system is Phenom II 3.3 Mhz 6 core, 2x Readeon 6990 video, 4x8gig @ 1866 Mhz Ram, Windows 10 X64, ALL drivers up to date (after confirming every driver needed according to system info), BIOS was not needed as I don’t need the upgrade for my system requirements, downloaded World Machine and bought the personal license, Had Visual Studio/Visual Assist for courses outside UE, Have Bridge…Plus what ever UE forums has recommended. I know it’s not the latest hardware, but, it should work on an empty project.

No matter how I word my search (and I’ve tried every fix suggested, and not to keen on trying 3rd party fixes. As they ALWAYS result at some point a virus or total reinstall of everything.

I can’t use DX12 setting, I think that’s because UE is slow to add AMD graphics cards. That’s fine. But, I can go on World Machine and choose an area @ 4033x4033 with export setting Unreal Engine 4, area, sqrd +1. and Import it fine, no issues. I spent the time, OVER and OVER using the recommended UE landscape settings and parameters using .raw16 and .png16. I can’t Import that same image above in a 4x4 (16 tile) mesh, using, 16x 2017 or 1009 or 505 or 127 export files. I can import each file individually but not import all as 16 levels. This is in world machine a Y23, X17 windows without a color texture node, Just height.

I have each one saved for each coord…ie, _X0_Y0, _X1_Y0, _X2_Y0 etc. up to _X3_Y3…what did I miss to mention…hmmmm…Yes, World composition is checked, I tried with and without SVT, I slapped my granma, did the 2 step, did the hokie pokie, I turned my self around and drank beer until I thought I was smart ( that solved a lot of world issues, but not UE issues) But, UE still shuts down and I get the report page. Looking through it, this is the only thing that i can as the issue:

Thalandir2.log (77.4 KB)

This is the line That stands out to me: Virtual Memory: 134208720.00 MB used, 9011.29 MB free, 134217728.00 MB total.

I’ve sent that in a ton of times and no results back

Again, when I choose DX12 I get DX12 is not supported and have to go back into defaultEngine.ini and change that back to defualt to get back into my project.

Please help! thank you

the way to do something without frustration is to take each thing separately and try to solve it.
you talk about 5 different things and its confusing for anyone to pinpoint what your problem is. I’m guessing its confusing for you as well.
so, trying to unclutter that mess, i conclude that the issue is that ue crashes when you do an import of a tiled landscape.
first of all, dx12 and visual studio and WM license have nothing to do with importing a tiled landscape.
now assuming you did all the pre-steps properly (creating a blank project, new map, enabling world comp, etc) and assuming you’ve read “hours” of documentation you should be good to go.
but what is this “world machine a Y23, X17 windows”?
have you tried importing just 2x2 terrain?
do you have enough space on the drive where ue is installed? apart from memory, ue saves those tiles as individual maps on your hdd.

the virtual memory error is weird, i’ll give you that but it might actually be an issue there. do you have issues with other 3d apps?

finally, when i had issues with tiled worlds these were very helpful:

Thank you for the reply!

First, I included as much information that I thought you would need without having to ask for much more specs and details.

Second your are right I should have said loud and clear what exactly I’d like to fix. That said I should have posed the DX12 issue as more of question. Like, is this the reason I can’t import a tiled landscape?

I didn’t realize it at first, but, the _X0_Y0 level gets added to the project. When I reopen the project again it is there, but no mesh. That said, I didn’t try to save it before deleting it.

I did try 2x2 tiled mesh several times, after trying the 4x4 mesh to cut down on time spent trying different mesh sizes to see if I did my math wrong for overall size post import, same results.

what is this “world machine a Y23, X17 windows”
This was my mistake, I read the wrong coordinates, those were the tile origin coords. The Map I chose to tile is 24x24 km. It is small, but this is Just a learning project for me so I don’t make huge mistakes in a larger one.

I’ll watch that video again and see if I missed anything from the notes I took.

Again, thank you for the reply, I will let you know how things work out in a few hours.

I forgot to mention, I’m only trying to import the greyscale height maps. As I am trying to learn to use Unreals blueprint system for creating height generated textures.

A few things I can see

Your hardware is definitely very outdated so that’s going to be a part of the problem, your GPU while it’s 10 years old it was higher end when it came out and it should be able to run the editor. However, it does not support DX12 so you shouldn’t be trying to run it under DX12, just run it under the default DX11. DirectX support is built in to the GPU so if it wasn’t released with DX12 support then it won’t ever support it.
Also as far as your GPU goes, you’ve got two cards there, I would remove one unless you have other software you want to continue using that takes advantage of both, UE4 does not support multiple AMD GPU’s and if you’ve got some AMD setting enabled for the multiple GPU’s it is likely causing problems with UE4.
Your CPU is very slow at this point. I don’t know if that is the main issue but it’s at least a problem.

Thank you for the reply!

I do realize my machine is outdated, Though I didn’t think for such a small project I’d have that big of an issue. I guess I need to upgrade sooner rather than later. Though with the current prices for GPU I won’t betting a new one anytime soon.

I didn’t realize the dual GPU would be an issue, I’ll try your recommendation and remove one.

Thanks a million!

I disabled the secondary GPU. It doesn’t seem to have been the issue, I’ll keep trying in the mean time to figure this out.

Another few things of note in your log:
[2021.06.16-21.03.48:201][ 0]LogD3D11RHI: Error: agsDriverExtensionsDX11_SetDepthBounds(1,0.000000, 1.000000) returned error code 6. *PLEASE UPDATE YOUR VIDEO DRIVERS
Your video driver is almost six years old, and UE4 isn’t happy about that, it’s a shame AMD stopped support for the 6xxx series, the 7xxx series driver is part of the new unified installers, you have the last driver created for it, it’s just ancient. DX11_DepthBounds is a feature that started with 7xxx series.

Also, is “134208720.00 MB used” a typo? because that’s 134.2 terabytes, what’s your windows virtual memory set too? If it’s somehow been set to that ridiculous number, and UE4 requests to use it, windows will probably detect an error and shut down UE4.

unreal isn’t too keen on very long file paths,
[2021.06.16-21.03.37:475][ 0]LogShaderCompilers: Guid format shader working directory is -29 characters bigger than the processId version (…/…/…/…/…/…/Users/rbuck/OneDrive/Documents/Unreal Projects/Thalandir2/Intermediate/Shaders/WorkingDirectory/4792/).

Grab a copy of the project and paste it as close to the root of the drive as possible to see if that’s causing an issue.
“The Map I chose to tile is 24x24 km.” That’s actually a huge map for your hardware.

I agree, I need a new…well PC haha… I’m looking at options to upgrade as I read this.

That line was actually copy and pasted from the log notes. I am 100% unclear what it means. I’ve never seen it before. So I don’t even know where to look to find the route of the issue.

I’ll give the file path a try and see.

As for the total size of the map, I can see that as an issue, but, as I said I can import that entire mesh not tiled fine. As well as import all 16 tiles individually fine as well. But If I try to import a 2x2 (25%) section, which is 6x6 km of that entire mesh, it shuts down UE.

I’ll try the file path right now
Thank you for your input!

File path isn’t the issue, in this case, I put a copy in desktop. same result.

I’ll bet it has to do with file name.

All my tiles are saved as: _X0_Y0.png up to _X3_y3.png and I have a copy of ,r16 for each tile as well, I’ve tried both files saved as 2017x2017 down to 127x127 and used both 1x1 and 2x2 for each as well.

And that virtual memory issue. outside the fact my pc is outdated.

First. World comp can crash a Titan if you don’t know what to do.

The leading issue?
Leaving the “mini map” open.

Many times it’s just there in its own window or UI panel. When importing tiles landscapes it is absolutely necessary to make quadruple sure nothing else in the engine is open.
No extra tabs, no extra windows, and most definitely not the mini map visualizer.

Closing it out if you have it open could potentially solve your problem.

  1. 4gb of vram is nothing. You can’t expect to be able to develop on such a low amount regardless of what engine you use.
    It’s literally barely enough to get games to run… I’m surprised you haven’t ran into a ton of other engine issues.

  2. if you aren’t under NDA, you could probably post your tile files and ask for someone to test and see if the tiles are the problem.
    Hint: they probably aren’t. It’s the import process that’s failing for you.

Let’s add 4 too.
With 4gb of Vram you’ll barely be able to open up 4 tiles at the same time when they are empty at 2017px per tile. I think that’s the size you mentioned.

On a 1080ti you can barely load 9 tiles of 8km each.

You should really update the gfx even if it’s definitely not the best time to do so considering there’s nothing good avaliable on the market… consider investing in a pre-built with a 3080…

Let’s also add 5…
Instead of importing the tiles all together. Go one by one.
Create the first landscape. Import the height map. Add the adjacent tile. Import the heightmap and continue on that way.
Painful, but its a solution nonetheless.

Thank you!

LMAO we can take down this post now…I know what i need to do haha
Going by the minimum recommendations on the I thought I could get away with a small practice project as a hobby.

Really truely I appreciate all the advice from everyone! Thank you!
I’ll be back when I get a big boy PC :smiley: