Sequencer Not Rendering Selected Camera

Both Level and master sequences are not rendering the correct camera, or are rendering a random shot that isn’t any camera in the scene.

My Master Sequence rendered the first camera shot properly. But no matter what I did, I couldn’t get it to render from another camera. When I render from a level sequence, it just shows a random shot that isn’t related to any camera in the scene. I’ve removed all cameras from my level but my cinematic cameras… I’ve removed any camera transforms in the level and master sequences. I see the camera shot I want in both the level and master sequences in the camera cuts track, and it’s the only camera shot in the sequence, but that’s not what it renders. I’ve tried adding cameras, camera cuts, shot tracks and nothing affects it. I’ve looked in the documentation, on Youtube, and I can’t find a solution that has worked. Is this still in beta???


Can you post screenshots of your Sequence? The camera cut track will specify which camera the sequence should look through when evaluating during render. The typical workflow is to have one master sequence with several shot track sections, and then each shot track section has a Camera Cut Track (with one section) that spans the entire duration of the shot.

You can also ensure you are using the game mode override to override to the GameModeBase so there is not player code that is interfering with the camera location.

1 Like

I definitely have the sequencer set-up correctly with the current camera selected in the Camera Cut Track. I’ve even deleted the cut-track and added a new one multiple times but everything in the Cut Track shows my camera, the move, all the elements but it’s only after rendering that I can see not the elements in my scene are showing-up.

I’ll look into the game mode settings.

Thank you for the help!

Did you solve your problem? I’m having the same issue.


Same problem here!

1 Like

3rd that. I am using UE5, so it might be a bug. Rendering picks some random location. Is there a specific game mode that should be used? Play In Editor starts at the correct location.

I solved the issue by adding my camera to the Camera Cuts layers in the sequencer.

1 Like

Also interested in an answer for this. It seems that my Camera cut with accept me binding my character blueprint to it, but wont use the specific camera within the character blueprint to render. I can select the camera see through it in the viewport, but when I click render it uses whatever location it thinks is best.

I tried that to with the camera cuts, and still nothing -___-.
Would you happen to have any other suggestions? Appreciate it.

Was having the same problem, found this lovely little button in camera cuts. “Unlock viewport from camera cuts”


Ok So, Ihad the same issue - I discovered that a pawn I was using, had Auto AI Posess swtched on, as well as some other bits that basically spawned the camera where the pawn was, rather than my sequence cameras. Check the settings on your pawns / pawn cameras.

I just had the same exact issue. First Shot (Sequence) worked fine the others did not during the render even though it look okay when played and the Camera Icon was selected in the Viewport. Also no thumbnails on the others.

To Fix: Double click each Shot/Sequence to open it up, Right Click the first main Line (Camera Cuts or Whatever) and select Edit Section, Camera Binding ID is Unresolved. Select your Camera in the sequence (the top choice).

Exit back to the Master Sequence and now you have Thumbnail and it works. Do this for each.


Problem with my renderings were that I have forced “disable rendering” (CTRL-R) on some of my camera actors. Those were not renderded in render movie queue.

Engine tried to warn me with red text “render disabled”.

Hi, I had the same issue but I was using Waterline Pro. Inside the Waterline pro, I had added “Activate attachment” and chosen camera. This locked the camera in a random position so I wasn’t able to render out my sequence as I was planning to. My advice is to go through your outliner and make sure you haven’t done anything similar. Hope that helps.

I was struggling with this issue as well. I made an entirely new master sequence, and when going to render it out, I was seeing other camera shots instead. Matter of fact, the program would taunt me by letting these little gremlin assets pop up temporarily in my world outliner while the video was rendering, and disappear promptly afterward lol.

Tried searching them up to delete them; nothing. Even went into the project files on my pc. Turns out I hadn’t gotten rid of a few Matinee tools. Hope my blonde moment might help someone else running on 2 hrs of sleep! XD

I had this issue with UE5! It was rendered with a none existing camera located at the origin!!!
After a crash, it was working as normal! UE5 seems not to be really stable yet…

Another issue I’m facing right now is that it renders also invisible assets in the outliner. But it might be another topic :slight_smile:

i too have the same issue kind of stuck with the render camera getting back to a different location. i have changed the HUD class , and game mode but still i couldn’t found any solution


I just had the same problem, and it was because I have instanced the camera into a level, but I forgot to change the streaming level method from BluePrint to Always Loaded.
I hope it can help you !

1 Like

The fix that worked for me? Add to your camera camera component the track property; “Auto Activate”.

I just had this issue of the camera pointing at nothing. Tried a few things.
I had a very simple sequence, so I added other cameras. Then I noticed that some of my actors, that could act as pawns, weren’t showing up. So I added them to the sequence. Still wouldn’t show up. Okay, so I figured there might be a flag not being initialized – I added a track for “actor hidden in game” and it was false, I made it true. Well, then I’m thinking; what if this is happening to the camera?
So, I add a track to my camera sequence and turn on “Auto Activate” – suddenly, what I see on the camera starts showing up in thumbnails on my camera cuts!

Usually my sequence master track is set to autoplay in the game because I’m sequencing FX. So, I guess since I was just throwing in a cam to shoot an image with MoveRender this showed up. Also, prior to that, I’d had a crash when movie rendering and that’s when I exported what I needed to image to a brand new project. I’ve had this happen in both UE 4.27 and 5 – so it might be after a crash, the “Auto Activate” flag is off on the MovieRender cameras by default and thus, it doesn’t show up to UE as an available camera.

The other thing I do of course is check to see if cameras are assigned to the cuts, and on “edit section” I always want to choose “Keep State” when section is finished.

This problem is happening to me in Unreal Engine 5.1. Everybody wants to sweep it under the rug but it’s a huge bug that needs to be fixed. I keep getting some weird shot from a camera that doesn’t exist under my scene.


Did you find a solution for this? I’m having the same problem in 5.1!