Sequencer mysteries and rendering wrong camera

Made a Sequencer Master with 5 sequences - seq 1 made fly thru - render - fine // seq 2 fly thru - render - not fine its going to the player start now and I can’t get back control to the output to not just render from the player start . Reloaded project and the one that did work nolonger does - will only render from player start and stay there - no level blueprints- gamemode on none - cinematic checkbox in render settings checked . I’ve rendered alot out of sequencer in multiple projects so not sure this one is stumping me as to what changed all of a sudden.
I can create another master cinematic with another 5 seq’s and they render right . What could I have changed in the Sequencer that tells the camera to choose the player start instead a of running the sequencer track ??

Simplified above //==========================================ranting can disregard unless you have an solution to the secondary gripes

Sorry for the long post but been using Sequencer for months and anguish has built up

I have been rendering out of this project file for weeks
Suddenly after working on a sequence the camera will not render the right view . I can go back into another sequence and it will -but I tried to go into another new sequence - I havnt touched it and tried to render and it flips to the unknown camera view ( ends up being default postion wherever that is after you delete player start)

So I made a Master Seq with 5 sequences
Made one fly thru - rendered fine
Made another fly thru - plays fine -can simulate and still play along camera track - won’t render right camera
there is no camera with the view it is rendering
there is no level blueprint
there is no player start or any real gameplay at all to gunk up anything (* so now its going to that default position with no player start*)

So when I went back to 1st seq and tested to see if its camera would render it worked fine
so - that should mean no REnder Movie settings changed

when I went back to 2cd sequence it would only render the camera from the first
clicked activate camera button in 2cd seq no effect
There is only 1 CineCameraActor in my outliner - there are 5 sequences in the master track so why ?
Both Seq 1 and Seq 2 share the same actor but the others have one that doesnt show up in the outliner how ?
What happens alot is for some unknown reason to me and it seems very random the camera inside a sequencer loses its camera icon and you can’t click on it any more to activate it
You then have right click and make posses-able to get icon back - why ?
After a few attempts to get rendering the Seq2 goes back to random spot thats under the ground .
So I re-added the player start and that was where it was going to -
but why is it stopping Sequencer from rendering ?
this makes absolutely no sense - why is Sequencer not the highest priority when rendering - nothing should override what you see when you hit play.
So I rebooted the project file
re-opened master Sequence go into the Seq that rendered fine
Seq 1 - the camera is in red ? So i re-attached it to what i think is the right camera even tried "rebind posses able references . it now will only render from the player start . Tried changing gamemode nothing - put back to none
From a filmmaking persons perspective this is soooo frustrating . If you put a camera in and set up its specs you want them to always be that not change - where are the pixel setup properties ? I want my cameras to be i.e 5000 pixels x 1500 pixels how do i set that up in filmback settings -? Why would you setup your camera with one spec then want to render it out to a completely different size ? Why put the pixel setup in the render window this is absurd - set ur camera up in pixels render to pixels - your not gonna want to randomly pick some pixel value that has nothing to do with your ratio of your camera. How do you even know what pixels are 150mmx45mm ??

Back to main problem
So why is this now only rendering out from the player start ?

And how do you get the blueprints to play while you are working and still save your changes ??
Do I have to hit simulate then play on timeline cus that will not show exactly what is happening when I do a fly thru if all the blueprints start firing and particles are looping they may not loop at the exact time as when the camera gets to a certain point so how would i know that a particle will fire at the right time ?

Did you get this sorted? I’m running into the same issue, when exporting from sequencer the camera is ignored and renders the movie with a still camera at 0.0.0

Nevermind. Found the answer: https://answers.unrealengine.com/questions/566991/sequencer-not-rendering-selected-camera.html Just add a “camera cuts” track to your sequencer.

Hey Danner34
Did you ever get this resolved?
I’m running into a problem where mid-render the camera switches to a 0,0,0 position and just sits there and renders.
Tudor

Hey Danner34
Did you ever get this resolved?
I’m running into a problem where mid-render the camera switches to a 0,0,0 position and just sits there and renders.
Tudor

Hey Danner34
Did you ever get this resolved?
I’m running into a problem where mid-render the camera switches to a 0,0,0 position and just sits there and renders.
Tudor

I answered here: Sequencer Not Rendering Selected Camera - Cinematics & Media - Unreal Engine Forums

did u ever figure out what the issue was my camera renders half way then like u said goes to another ghost camera and renders the floor sequences.

Your answer didn’t work for me, but found this one that did work (at least in my case). I already had a “camera cuts” track on my sequencer. Right click on the filmstrip image along top and click on the “change camera” section to select the camera you have assigned if it has somehow gotten out of sync.

1 Like

This question is so old I can’t remember how I solved it. The good news is that I haven’t run into any issues any more, it was user error most likely. Now I just make sure the film strip images are stretched to fill your desired frames in your camera cuts track and that the camera icon in the camera cuts track is highlighted.

Hi i had the same issue,

my problem was , i have multiple levelSequencer, and when i try to render one of them, sometimes the camera and shadow was not right.

it was becaus i had on my world outliner a levelSequencer player set on my master sequence and it was set in autoplay.
i just delete it and it render correctely (4.26)

Have nice day
Daniel

I posted a similar question here: Level Sequence Camera Issues 4.26 as the sequencer cameras are making me FREAK OUT at this point.

I’ve tried everything listed here – making sure “restore state” is listed in properties, making a master sequencer, deleting that master sequence, ritual sacrifice… – but my game still randomly switches to a sequencer camera during gameplay, breaking the game, and some of my sequences play and then do not revert to the player camera.

Any advice as to where to go would be huge because I don’t know what else to do. Thank you!