Self Shadow Only in static lighting

It seems that SelfShadowOnly doesn’t work with static lighting. Simply check a box “Self Shadow Only” in StaticMeshActor, and rebuild lightmaps. Shadow appears in lightmaps even if both mesh and light are marked as static.

Hello Esidar,

Which version of the engine are you running?

I tried testing your issue on the binary release of 4.6.1 and was able to get the ‘Self-Shadowing’ to work with Static lights.

Perhaps you can provide me with a screenshot of you Static mesh and your light properties you are trying to get this to work. Also, if you could provide me with some reproducible steps that would be helpful as well.


I’m sorry, I didn’t gave you a repro right away. It looked like a 100% repro to me :slight_smile: I did it with 4.6.1, and now, I’ve also downloaded 4.7 pr3 and have the same result.

I’ve started new project “First Person Shooter”, grabbed DirectionalLightStationary, changed it to Static, then selected one of the cubes, changed to Static, and checked “Self Shadow Only” flag. I’m attaching a screenshot: on the left side, there’s no shadow (it dissapeared after selecting “Self Shadow Only”), on the right side there’s a shadow after calculating a lightmaps.

The SelfShadowOnly feature is for dynamic shadows only - it allows to have a first person weapon in high quality without casting a shadows onto the world. I guess the name should have the word dynamic in it. We might be able to make it consistent for static shadows to make it less confusing. I created a task to fix that. Fixing it for static shadows might be hard as it can break the GI computation to have artificial non physical things happening there.

Any word on whether this will be applied to static shadows as well? I’m currently having to bake self-shadowing into textures.

hey rohoon,

as mentioned this is a dynamic shadowing feature and is not meant to be used with baked static lighting. You might be confused as he mentioned editing the tooltip to be more consistent with the feature itself.