Screen space Widget Component in VR

Widget Component is rendered incorrectly in a screen space in stereo rendering mode (VR). Actually, it’s simply rendered in a normal flat-screen space. I understand what’s a problem here and why it can’t be easely transferred to stereo screen, but this or equal feature is really necessary for interface elements placed in a world. Widgets in world space are ok, but in many cases we need intetface elements that can’t be occcluded by other objects. Obvious example is a highlighting circle pointers in the Arizona Sunshine game.

Hello YuriNK,

If you would like for our widget component to appear over top of other actors you could use “disable depth test”. You will need to change this property in the material that is applied to the widget component. I have provided a link to documentation on this feature. I hope that this information helps.

Link: Material Properties | Unreal Engine Documentation

Make it a great day

Hey YuriNK,

I know this is a bit of an old problem, but I’m having the same issue. I’m developing a VR application and I need to display a widget component in screen space.

I attached an example of what I’m trying to do in VR.

How did you managed to work this around?