Download

Scene with Forestry causing lightmass to crash

Hi guys,

I’ve been working on a little scene to try out landscape and interior environments and my lighting will not build. The lightmass always crashes and I get the attached error screen. I am using trees from the free vegetation pack, any idea on what to do? I tried lowering the min lightmap resolution to 16 and I still get this.

Please see the above link to help you out mate :slight_smile:

Thanks for the reply, I have a importance volume around the architecture of the scene, not around the landscape. No matter if I build using the preview or production settings it is always stuck on building 0%

When you build the light, open “swarm” (the yellow icon in the systray) and check if there is still something moving + what are you pc specs + how many foilage do you use in your level? :slight_smile:

@fighter I will be able to check the exact amount 2n when i get home. Total holy **** moment but you are the one that created the vegetation assets I’m using, great work!!! What is a quick way to see how much foliage is in a map? Look at the paint landscape tab and count the amount of trees or is there a dialog that says that?
PC specs are i5-3570k, 16GB ram, Nvidia GTX 980, asrock z77 mobo, Intel 128GB SSD, 1TB Baracooda, 2TB Baracooda.
The error is tied to my instanced actor which are the tree from the veg. pack abd the sm_field_grass mesh from the kite demo. It is tied to the lightmass resolution but how can i lower it for each mesh?

It looks like it’s trying to use 58GB of RAM

Either your lightmaps on the foliage is too high resolution, or you have too much foliage which could mean your level is too big to use lightmass and you’d have to look into a dynamic lighting solution.

Yep, I’m the one from the vegetation pack :smiley:
You can see the amount of meshes in the foilage tool.
As darthviper107 mentioned, in cases, where you use plenty of foilage, it’s better to use dynamic lights

Sorry for the noob question but what would be an example of a dynamic light?

Really great work fighter! Since you are the maker of the asset how can I lower the lightmap resolution? How do i got about accessing that parameter? AGain thanks for your help through all this.

Click on your light - in the details panel you have to set it to moveable :slight_smile:
You can change the lightmap resolution in the mesh editor -> double click on the mesh in the content browser - right side of the window - lightmap resolution

Okay I will try 2n, so this is just for my directional light, correct?
I will try this and let you know how it goes…again thank you so much!

Also set your skylight to moveable -> then you wont have to build the light

fighter, you’re a genius. It works perfectly, no need to build the lighting using the move-able! Here’s a link so you can see your work in action in a piece i’m doing to learn UE4. Slack

Glad you got it sorted :slight_smile:

Could you upload the pic on gdrive or directly in this forum? -> I dont have a slack account, but would like to see the result :smiley:

Whoops, I was getting errors trying to upload through the forum, here is a gdrive link, enjoy ue4progress - Google Drive

Already looks good! :smiley:
But I personally would change some stuff:
-decrease the bloom intensity a little bit
-change the grass colour so that everything fits together
-it seems like you are using the “low” quality settings -> set them to epic