Rightclick on asset needed to be used in UI

Branch: Binary


Desc: So this Problem occurs after every single restart of the Editor (Start from Visual Studio)

I have set up an Image in my UMG “MainHUD” Widget. The Image is bound to a reference that is stored in a DataTable like this (Excerpt from CSV) :


That works totally fine AFTER i rightclicked on the referenced Image. If I dont, the Image is all white. I attached a gif to demonstrate.


Hello TobeyEU,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick Questions:

  1. Can you reproduce this in a clean project?
  2. If so could you provide a detailed list of steps to reproduce this issue?
  3. To clarify, does this issue only happen when launched from Visual studio?
  4. Could you provide a screen shot of the blueprints that are involved?
  5. Does this still occur is stand alone?

It´s kinda late now. I´ll try all that tomorrow and let you know.

  1. Yes i can

  2. Steps to reproduce

2.1. Create new c++ Project with First Person Template

2.2. Add Code To Project via Editor

2.3 Header-File:

    #pragma once
    #include "Engine/DataTable.h"
    #include "TestTable.generated.h"
    struct FTestTable : public FTableRowBase
    	UPROPERTY(EditAnywhere, BlueprintReadWrite, Category = LevelUp)
    		FString Spellname;
    	UPROPERTY(EditAnywhere, BlueprintReadWrite, Category = LevelUp)
    		TAssetPtr<UTexture2D> Spellicon;

2.3. Create CSV-File like that:


2.4. CharacterBlueprint


2.5. WidgetGraph


3 No, It also happened when i started it from launcher

4 see 2

5 Yes

6 During testing I stumbled upon similar problems with other things (the ReflectionCapture included in the Template, a Static Function i wrote in Blueprints and a struct I get from a DataTableRow)

6.1 every start has to be updated, or nearly everything on screen is white
6.2 Errormessage: Error The current value (/Engine/Transient.REINST_StaticFunctions_C_1) of the ’ Target ’ pin is invalid: /Engine/Transient.REINST_StaticFunctions_C_1 isn’t a StaticFunctions_C (specified on pin self)
where the function is used it has to be deleted and put in place again. This occurs the first time after the restart when I try to compile the BlueprintFunctionLibrary the function is implemented in.
6.3 struct →


This problem only occurs when I start the Editor from Launcher, not when started from VS.

Sorry for the wall of text but the more you know the better, i guess

Hello TobeyEU,

I could not reproduce this on my end. I was able to use your code and it worked just fine. I would like to make a small note. I took out some extra quotations (“Texture2D’/Game/Abilities/Icon/Fireball.Fireball’” this is what I used) out of the file path and then re-imported it.

I was wondering if it would be possible for you to send us the project that you are having this issue with?

For testing purposes I tried the thing you did with the file path. It doesn´t work with me. Thats the new CSV (the last line is like it was before, the Fireball-line like you suggested.).


After reimporting the resulting DataTable in the Editor looks like this:


Maybe I did something wrong in there?

Note: IIRC i didn´t type the link in there, I got it by rightclicking on the Icon in the editor and then “Copy Reference to clipboard” or smth like that

Hello TobeyEU,

I used the same method (Copy reference to clip board). Would it be possible to provide us with your project or simplified version that still has the same issue?

The Project that makes problems

Hello TobeyEU,

I am having a few issues testing the project that you provided. Would it be possible for you to provide the CSV files that you used for the project?

Hello TobeyEU,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

I am encounter the same problem, but i don’t seem this post have any solution that works for me…

Hello WindLegend,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. What version of the engine are you using?
  2. Can you reproduce this issue in a clean project?
  3. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  4. Can you provide a screen shot of this issue?