Rendering issues with Directional Light in UE 4.11

Update: We found new information about the problem:

Dear Epic Games,

Our team have encountered a problem in the rendering pipeline. Some “random” black artifacts. We tried to isolate the problem from the whole level and now we believe that the Directional Lighting is the cause of this behaviour together with the material setup. Artifacts appear not only on character meshes, but also on any surfaces (with some material setup), which are oriented as similar to vector of the Directional Light source. Right now we don’t understand which Material properties causing the bug. Supposably Reflection/Roughness. And this is not dependent to Subsurface Profile Shader Model (other level props and objects cause this problem too). That’s all we investigated for now.

We can send you our isolated test scene if necessary. But only privately. I’m attaching the screenshots of the problem:

Pay attention to the Directional Light vector:

Directional Light (vector) is rotated:

Directional Light is turned off:

Thank you!

Hi Dmitry,

If you wouldn’t mind sharing the project I can have a look and see if I can narrow down anything. You can send me a link in a private message on the forums.

I did a quick scene setup using the settings I could see turned on in your details panel and I didn’t see the same results. I only used a basic skeletal mesh character though with basic material setups.


Having this issue also. I think it’s a problem when material roughness is really low. (0 for our case.)

Would be great if Epic fix this soon.


Without additional details it’s hard to guess what may be the issue here. If you have a solid repro or a starting point I can give it a shot. Adjusting the Material roughness didn’t show anything promising on my end.

A fix can be put in the quicker a ticket is put in.

So if you have anything regarding how the scene is set up like

  • Lighting settings
  • Material graph
  • what makes it happen vs not, such as light rotation, changed settings on your light or assets, etc.

These are just starting points to start investigating. We have a lot of reports coming in and we cannot dedicate an endless amount of time to one issue unfortunately. Any help is greatly appreciated so this can be reported and resolved as quickly as possible.

Thank you!

I’ve sent you a private message on the forum. Thank you for your help.

Thank you! I’ve got the test scene. I worked with it a bit yesterday to try and recreate in a new level, but it wasn’t able. It’ll probably take a little bit of time for me to debug and also recreate in 4.10 for comparison. Thanks for your patience.


I uploaded the version for UE4.10.4 for you to the same address. Let us know if we can provide any further assistance.

oh! That’s great and helps a lot!


I don’t know how the notification system is working here, so I just want to inform you about our progress on our side. Please look to the updated information in this post. Thank you for your time.


Try to increase “Min Roughness” parameter of your Directional Light (“Light” > Advanced properties). In our case, restoring the default value (0.08) is the solution. I’m really interested. Does it help to solve your problem too?

We had the same issue and this fixed our problem.

Temporary solution: Increasing “Min Roughness” parameter of Directional Light (“Light” > Advanced properties) or restoring it to the default value (0.08).

But I still think that it’s a bug and not a desired behaviour.