Rendering Issues after merge conflict

My friend and I worked simultaneously on our project the other day. We tried to go out of our way to make sure that I only modified scripts/source code while he had free reign to edit the level itself

Long story short we end up still having merge conflicts when I attempt to pull his changes from the remote. The only file conflicting happens to be the .umap file so I handled the conflict by just taking his copy of the file using “–theirs”.

Initially it appeared as though everything went fine. My source code changes are still present in the merged project while his map is being used. However, on attempting to play the level, nothing renders. No lights, no models, and no collision. As a result, all that is shown is a black screen.

I’ve figured out that moving the location of the spawn point does change the amount of time that the player remains active in the level. This leads me to believe that the player is being spawned properly at the location specified by the FirstPersonCharacter but then falls to its death at the “Kill Z” threshold.

I’m really not sure what the problem is so if anyone has experience with these issues any help would be appreciated. I’ve attached the most visually informative thing I could get from a test. It’s simply the world grid being shown after ejecting from the player.

Just solved this the other day. Turns out we had been introducing level streaming to our game and didn’t know that levels have to be manually loaded once they are chunked into levels.

So, mark you answer as Solved please :slight_smile: