Render target cause fps loss because of Volumetric Clouds

I noticed that volumetric clouds cause fps loss when using a render target. So is there a way to not render volumetric clouds in scene capture component 2d?

Dear valued Unreal Engine user,

The scene capture component should have the option to set the ShowFlags.

You could try disabling VolumetricFog for example. An alternative might be to use the HiddenActors or HiddenComponents and hide the source of the fog/clouds.

If that does not work, you may be able to look into setting the scalability group e.g. sg.effects or sg.postprocessing before/after taking the scene capture.

Thank you for your continued support,

Anthony

Thank you for this, the flags did the trick, I’m using the ShowOnlyList array and the new volumetric clouds were still rendered, modifying the flags did the trick for me.

what flag did you turn off?

Atmosphere

This works in the editor but not inside of a shipped build for me, anyone else with this issue?

This seems to still be a problem in 4.27.2 - The performance hit is huge when using a scene capture component. In my case I’m using it for a portal, I’ve tried many different settings/flags to get it to perform better.
Only turning the clouds off completely or ticking off the Atmosphere flag works (which I’d rather keep!). If anyone found a solution to this I’d greatly appreciate knowing how you did it!