Download

Remote Control Web Interface - Cannot get / Error

I am trying to get the Remote Control Web Interface. I followed the documentation but I get stuck when I want to open the interface on the browser.
localhost:7000 shows me a message

Error.
I have tried to change ip to 127.0.0.1:7000 also disabling firewall but I still getting the error. I believe is an error that is coming from node.js.

Do you have any fix for it?

Check which port your Project server is configured for. ProjectSettings->Plugins->WebRemoteControl. Confirm HTTP Server Port <XXXXX>. In your case, you’re looking for port 7000.

Also, make sure the game web server is running

Check the Output log. Run either and see that your server starts.

Cmd: webcontrol.stopserver
Cmd: webcontrol.startserver.

Same problem

I had the same problem. My issue was I had Unreal installed on a D: drive. I uninstalled and installed on the C: and the cannot get error was gone. Hope it helps.

Ran into the same issue. Have you checked which version of node you have installed?

At the time of writing the docs say that node version must be:
8 < version < 14.15.5

I had v16 installed, which resulted in the ‘cannot get /’ error.

To get around this I uninstalled node completely and installed nvm (GitHub - coreybutler/nvm-windows: A node.js version management utility for Windows. Ironically written). On windows with nvm, you install multiple versions of node and easily switch between them. For the latest verson (so you stay up to date for other purposes):

nvm install latest

To install the latest version compatable with the remote control web interface:

nvm install 14.15.5

To use this version:

nvm use 14.15.5

To test that node is running correctly

node -v

Which should return:

v14.15.5

Next, uninstall the remote control web interface plugin from epic launcher. Navigate to:

C:\Program Files\Epic Games\UE_4.26\Engine\Plugins\Marketplace

And delete the ‘RemoteControlWebInterface’ directory.

Head back to epic and install the web interface once more. Boot up your project and it should rebuild the depndencies once again (this time using the supported version of node).

Worked for me, hope that helps you!

1 Like