RemoteControlWebInterface not starting on Mac (M1)

When i try to add the RemoteControlWebInterface Plugin on a mac, i get

Error: [Failure] Failed to Launch the Remote Control Web Interface - WebApp exited

while the same procedure works on windows. This happened to me on UE4.27 and UE5.

What i tried:

  • Downgrade node via nvm to v 14.14.0 as suggested in this thread
  • disabled Apple AirPlay because that blocks port 7000

I noticed i get this warning just before the launching of the plugin fails:

LogRemoteControlWebInterface: [Pending] Launching Remote Control Web Interface - /bin/sh: /Users/Shared/Epic: No such file or directory

Which makes sense, bc. the directory is called “Epic Games”. So it seems like executing the plugin fails because of the space in the folder name??

to fix that i tried moving the RemoteControlWebInterface Plugin to a local plugins folder, but then i get

LogRemoteControlWebInterface: Error: [Failure] Failed to Launch the Remote Control Web Interface - Couldn’t find node.js installed…, Please install latest nodejs from Download | Node.js

instead, which also doesn’t make any sense.
My Mac setup is pretty straightforward so i’d expect others to have the same issue?

1 Like

One more finding: In the plugin directory, i can manually run /WebApp/Scripts/start.js and then a node app is being built and run. Subsequently i also get the to the web interface and it connects to the API! But it still doesn’t work because the Unreal plugin still doesn’t start and so i can’t add any properties to my RemoteControlPreset - Because the eye-button next to the properties isn’t there…

i have the same problem.
I think is related to the path so I’m trying to make it work because looks like is trying to find the remote control here /Users/Shared/Epic but the complete route is longer : /Users/Shared/Epic Games/UE_5.0/Engine/Plugins/VirtualProduction

Has anyone found a solution to this? I’m having the issue currently. Was originally working in UE5, then installed 4.26, then upgraded to 4.27.

I installed NVM and installed Node.js 14.15.5–still nothing. I keep getting “can’t find Node.js installed”.

If it’s a path issue, how do I resolve this? How can I get UE to point to the correct folder? Is that even the issue?

I’m at a loss why some people have it working while others don’t.

Note, I’m on a Mac. Could it be a Mac issue?

I’ve this exact problem right now. Any solution?