Reflections have super bright spots

Reflections have super bright spots. I attached screenshots illustrating this. These bright spots are all over the place when i have glass with reflections… it has forced me to turn off bloom which i do not want to do. I had to turn off bloom because every window looks like the brightness of a nuclear explosion… Blinding… Any ideas why this is happening?

It seems like these bright spots come from pointlights… since when i delete them i no longer get bright spots… This looks ugly as heck. So why do i have super bright point light spots in my scene in reflections only…? since the scene itself the light isnt that bright.

Do you have reflection capture actors in the level? And does it still look like this after building the lights?

Yes, these are all reflection capture actors… and yes it does this after i build lights. Dont think the bright stuff happens on screenspace… screenspace is disabled here. It will always do it on reflection capture actors though.

This is a known issue that has been reported with 4.9 with the introduction of Static Lights being captured in the Reflection Captures.

It was reported with UE-19818. Ideally you would be able to use the min-roughness setting to reduce light acne that is caused by this, but that’s a limitation of the implementation at the moment.

You can try increasing the source radius of the static light to see if that helps reduce the artifact though.

I hope that helps.

Tim

Hi! has this issue been resolved in future releases? Im currently dealing with something similar on version 4.23

i beleive (if i remember correctly) there is some setting in the light now for specular scale that can be used to remove these if i recall… id only mess with them for static lights.