Reflection Captures black 'end of world' effect

Hi, i’m having an issue with large open environment reflection captures (both spherical and box) not capturing the extent of the scene - leaving it as a large black area. Below is an example of this looking into a mirror with SSR disabled for clarity. I have a near-infinite plane along the ground which is being cut short - however the sky is being rendered to the reflection map at much further distance, are their some settings required for this that I’ve missed perhaps?

Many thanks

b14de

Hey b14de -

Two Questions. One, Are you using a skylight in your level? Two, In your world settings lightmass, what is the environment color set?

Thank You

Eric Ketchum

Hey Eric, much appreciate the reply.
I do have a skylight with the following settings:

My lightmass environment colour was set to clear on the last bake, however changing it to solid blue doesn’t appear to change in the cubemaps after updating reflection captures. Does this param require a lighting rebuild to update the cubemaps also?

Hey -

So I just want to ask though I am certain I know the answer, have you built lighting? Also uncheck the Lower Hemisphere box and rebuild lighting to test to see if that clears up the issue.

Let me know -

Eric Ketchum

That was the one, thanks for the help there Eric, works great now.

Doesn’t helps
Update: I changed Reflection Capture’s “Intence radius” and all working (after I moved things around they’re correct)

The original user was having a specific issue with teh sky light and sky box, but also if your Sphere Reflection Actor cuts through an object with its Influence Radius that section of the Cubemap generated by the Capture Actor will reflect black. I am glad you got it correct though.

Thank You

Eric Ketchum

try to set Directional light settings > reset all the shadows settings do the same in world shadows settings after set sky light to stationary verify directional lighting settings > cascated shadow maps and reset settings, verify again world settings >
light softness and reset after build all… sorry for bad english

Changing the skylight from movable to static fixed it. It could also be set to stationary, but that seemed to produce lots of unnecessary blue light in the shadow areas. Thanks!

THANK YOU ERIC!!!