Red atmospheric fog, can't turn it white.

Hello, my problem is about red atmospheric fog. Its the same color since I’ve put it in my level. I’ve tried to change its settings, putting skysphere and attaching directional light to it, building lights and many more but still I can’t get this fog to appear white like the natural one. Screenshot below.

Try taking a look at our documentation user guide for this and see if that helps:

You may want to use Exponential Height Fog instead as they may work better for the results you want to achieve.

Thank you!


FWIW I have run into this bug many times in the past but I am not sure what caused it or what made it stop occurring for me. Can you try deleting your atmospheric fog and directional light, making a new level (the one with a sky), and try copying that fog and sunlight actor together into your level and see if the fog is still red? I think I used that method to work around the bug. It was either that or use the startup map as a new P map and import the rest of my level (without fog or sun) as a streaming sublevel.

If you rotate the atmosphericFog controller by 90 degrees on the Y axis it seems to sort itself out but I have no idea why this bug appears.

Play around with Altitude Scale or Density Height options to fix this.

Actually, to fix this inside your Directional Light actor make sure you tick the Atmosphere/Fog Sun Light box.