Really bad quality megascans assets when zooming in unreal engine 5

I have this bug where almost every nanite asset from megascans looks terrible upclose. When i first used UE5 i didn’t have this problem at all, everything looked amazing and detailed, and suddenly after starting it up again it started to look crappy. Ive tried starting new projects, and even reinstalling but it just won’t go away.

1 Like

hi @StimpySem,
Have you updated your Quixel Bridge app for Megascans
Quixel Bridge 21.0.4 Update to Unreal 5.0 EA2 Epic Launcher Binary version

The UE5 source code is updated some people say there is a problem with version 21.0.5 but I can’t find any problems. Remember to unload the plugin in your project restart editor, re-enable the Bridge plugin or the project will remain at 21.0.3 or earlier​:cry: then 21.0.4 will work​:joy::heavy_check_mark:

Thanks

1 Like

I have reinstalled it so it must be up to date by now. The weird thing is just that everything was working fine till suddenly when i started it back up everything was low quality.

1 Like

I have the same problem on UE5 Preview2

1 Like

You need to switch to DX12 or Vulkan, DX11 is not suported anymore, I guess you see the fallback meshes.

I am on DX 12

I want to use this for creating close up Cinematics. This is a nanite megascan rock with moss at close up. Is this what is expected?

This is exactly how all of my meshes look, i know so many others who have the same problem. Nobody seems to know why this happens

Yes, I can confirm, some megascans are not looking good at closeups, because they only scanned them from far away. I think this one is supposed to be used only from far away.


1 Like

It looks to me like your project is using the Fallback meshes instead of the Nanite meshes. This is most likely caused by new DirectX12 requirements I outlined here. Hopefully updating your Windows OS to the latest version is the main culprit, but there are a couple options.

1 Like

Thanks for your reply, i found out that my settings were still set to DirectX11, so i fixed that. but still after opening a new file and using megascans assets they still look like this. I have updated my drivers and windows. Any other tips that might help fix this problem?


Same Issue here. But nobody seems to know the answer. I did a close-up scene before and it looks all amazing like it should. But when i startet a new project with the same mega scan assets it looks like total garbage. There are so many people with the same issue going on out there. HELP!

1 Like

Same here, need help…

I have the same issue but with a small twist. The first megascan object that I add for the project looks amazing, but starting from the second one and further they all start looking like some ugly spawns of hell.
I have tryied dozens of combinations of nanite settings and LOD’s but they just simply don’t affect megascans in any visible way.