Really bad lightning after build

I’ve been trying to get the most simple object in ue4 that i made using blender. But the lightning is always this bad. It looks good before a light build but its getting messed up like this after one. I’ve changed the light source index to the correct one ( blender lightmap pack ). and removed every lightsource and added a simple point light. I’ve also tried to increasethe light resolution to 512 but doesnt make a difference. I’m new to blender and ue4 and am trying to make a simple map with grates like this on the floor. Any help is appreciated!

I think that’s the UV map. Lighting should go in channel 1 in UE. Either way, it looks like there’s a whole load of overlap going on…

It may be the UE Import settings used too. There certainly is overlap in the lightmap shown in the screenshot, so it’s probably that. But in the case fixing that doesn’t fix it entirely, check Import settings for incompatible / non-applicable settings. For instance, ensure that the mesh is transformed to UE space from Blender space, and that the normals from Blender are kept / preserved rather than generating new normals by Unreal Engine.

If not keeping the UVs from Blender, then in UE mesh editor settings, do the following:

Enable “Generate Lightmap UVs”
Ensure Source LM Index is 0, and Destination is 1
Lightmap Coordinate Index set to 1 (not 0 as in above photo)
In Import Settings, enable “Generate Lightmap UVs” if re-importing

Post a screenshot of the Export (from Blender) and Import settings (in UE) if re-importing. If not re-importing, post another screenshot of the UV layout in UE after fixing the overlap (either having done it in Blender or by generating lightmap UVs in UE).

Thanks for the fast reply!
I’ve quickly made a new object in blender and checked the normals. I’m exporting it as a .fbx.
I’m using the unreal generated lightmap and set the correct indexes. It doesnt give any single errors anymore, but it still doesnt look very right. The shadow are smoothed alot. and some corners are missing.

Open it in the mesh editor in UE, and enable “Generate Mesh Distance Field”. Wait for it to generate the distance field that shadows the mesh. If it’s not a complete shadow still, open it in the mesh editor again and enable “Two-sided Distance Field”. It’s suggested to use a two-sided distance field for shadowing objects with thinner geometry such as fences, grates, and such. If all that doesn’t work, it could be a different setting for the mesh (in its details panel), or something to do with lighting in the scene.

Your lightmap UV’s are really bad, there’s a much better way to unwrap the UV’s for that, if you did a planar mapping of the wall and then used a flattening algorithm it should flatten it out pretty evenly without any extra seams except the outside seams. The way you’re doing it is an automatic method which is detaching many faces and results in lots of very small islands which gives bad results.

It’s strange how the shadowing for the object is different from the 3rd screenshot to the 4th. The 3rd one looks fine, but the 4th (last in the list of the post) appears to get shadowing at the nearer side of the grate (to the camera). Have you figured out what’s wrong with it yet?

On a side note, I imported a more complex model from Blender into UE4 that was quite pixelated and got it to display correctly by changing one or two settings in the mesh editor’s build settings. There isn’t much curvature in the grate model there, so it may not apply, but testing it probably won’t mess it up because it can be changed back or re-imported. The settings I tried were:

Compute Weighted Normals
Use High Precision Tangent Basis
Use Full Precision UVs

Try each one separately, and then combined to see how it changes it.