r.forwardlighting 1 broken in 4.12.5?

I just made a 4.12.5 copy my project (from 4.10.4) and am experiencing nothing when enabling r.forwardlighting 1. Was this feature changed somehow? It is necessary for my glass shader and worked quite nicely in the project before.

Hi doggy,

It is still working as intended. Make sure that you’ve setup the material to use Surface PerPixel (Experimental). Otherwise, the command for r.ForwardLighting 1 will not do anything.

If you’re still having the issue try creating a new blank project and seeing that works.

Hi ,

I’ve reopened my project, resaved the material + toggled the setting on and off and suddenly it’s working again! But now I believe I’ve spotted a new bug. When using a roughness value of 0 with r.ForwardLighting 0, there is a large black artifact. Using anything above 0 displays as expected. See the animated gif below showcasing the difference:

I was able to reproduce this by doing the following steps.

  • Create a Translucent Material with Lighting Mode set to Surface PerPixel
  • Enable r.ForwardLighting 1
  • Add material to an actor in the scene
  • Add a Skylight actor to the scene
  • Build Lighting
  • Disable r.ForwardLighting 0

At that point I noticed the black area on the material that wouldn’t go away unless Forward Lighting was enabled. When I tested this with our internal build of 4.13 it seemed half fixed on the build I was using. It had the black area but was flickering. I’ll be testing this again on a later build today and see if the issue still persists. If it does I’ll go ahead and enter the ticket for it to be investigated.

I have found ANY transparent material in 4.13 / promoted, will NOT build out… all objects are there but completely invisible.
I was building for GearVR and have never had transparency problems in 4.11, I have notm and since 4.12 does not have any VR templates plan to use it. Going with 4.13

I tried rebuilding 4.13 engine 3 times this weekend and made many project versions and settings and have come up with same end each time. TRANSLUCENT / TRANSPARENT will not render.

I loaded into a PC project and used starter content and pulled in some objetcs with transparencys and saw on the small statue the (above post) artifacting happening too. I have not built a PC project as I did with GearVR. Since that is not target output.

I am going to make a stand alone post here about it,but saw this post was close to what I was encountering. (sorry fer typos)