Download

Quixel Bridge Failed to restart background service

Hi @Gary10G,
The main problem is that node-bifrost.exe is viewed by many AntiVirus products as a Rogue Program.

In my AVG, I had to put it on the Do Not Disturb list.
ANY update to the node-bifrost.exe must be updated on the Firewall setting including as described above the BullGuard, others include ZoneAlarm, AVG Internet Firewall, McAffee Windows Firewall WinSock blocker. The AntiVirus may still block the program
I wrote the following answer I cannot put the original Quixel Questions as to its confidential

  1. Yes node-bifrost.exe is in the location stated. In my case AVG free was blocking it.
  2. I have put this node-bifrost.exe on the “Do Not Disturb list”.
  3. C:\users\owner\source\repos\ue50ea\engine\plugins\bridge\thirdparty\win\node-bifrost.exe
  4. When I open this I get a Windows Console Windows.
  5. Task Manager says its Node.js: Server-side JavaScript running

The other thing is that node-bifrost.exe is now has an entry in the Windows 10

Windows Defender Firewall → Allowed Applications

C:\users\owner\source\repos\ue50ea\engine\plugins\bridge\thirdparty\win\node-bifrost.exe

The Public box is now ticked

Hope this helps

Hi Jimbohalo10,

My situation turns out to be a little different, and thankfully, it has been solved. Yippee!

Several days before the 2021.0.3 upgrade, I had gone to preferences and changed the location of the Megascans Library to a different drive from where it was originally located within my UE5 project folder. When I did a drag and drop of Megascan assets from within UE5 the assets went directly into my project content folder. They did not go into the new location. When I updated Bridge to 2021.0.3 I think the two library locations were both “listening to 5017” simultaneously, and that created the conflict, which made Bridge continually stop and start the background process. So it became impossible to use Bridge.

Solution: I went back into Bridge preferences and changed my Library path back to my original project path. Now everything works perfectly! Before the upgrade, I would drag in the assets, but they did not come in as nanite enabled. Now they are coming in as nanite enabled so everything is working properly and it’s a pleasure to use.

I hope this will help to solve the problem of “background process stopped” for others as well.

I’m on Win 7 64bit, this fix may not work if you’re on a different version of windows, but this fixed the issue for me:

I was able to fix this issue by following "aefx0r"s above advice, adding the environment variable in windows, and then I also had to manually run node-bifrost.exe, and keep it running in the background as long as I’m using Quixel Bridge.

In case like you don’t know how to add the environment variable like I didn’t, just follow these steps to save yourself from figuring it out on your own.

  • Open your start menu and right click “computer”

  • Select Properties

  • Select “Advanced System Settings” from the left side menu

  • Click “Environment Variables” at the bottom of the “Advanced” tab

  • Under “System Variables” click “New…”

  • Set Variable name: NODE_SKIP_PLATFORM_CHECK

  • Set Variable value: 1

  • Click OK. Close all computer properties menus. Restart Unreal Engine if open

Now locate your Unreal engine install location, default:

C:\Program Files\Epic Games\VersionNumber
or
C:\Program Files\Unreal\VersionNumber

from here locate \Engine\Plugins\Bridge\ThirdParty\Win

You should find node-bifrost.exe here. Run the exe and allow private network access.

Now Quixel Bridge should be working properly as long as you keep node-bifrost.exe running!

To make your life easier, I suggest making a shortcut for node-bifrost.exe on your desktop or preferred location, so that you can easily locate and run it whenever you want to use Quixel Bridge.

Hope this helps! Stay creating.