Download

Quixel Bridge Failed to restart background service

cant log in to Quixel

3 Likes

I have the same problem, did you fix it?

2 Likes

me to

Background internet makes the entire Megascans library instantly available over your local network through Bridge. The library is always updated with the latest assets added every day through a background syncing operation.

Looks like your internet Windows proxy firewall is not allowing the background syncing operation or login according to the quote from the Quixel Bridge Manual.

Is there a fix for this. there is no info to be found on exactly how to resolve this issue. The popup keeps showing up every 12 seconds, and it makes in unable to downloaded assets for UE5.

i dont have a firewall enabled same issue

BUMP

It was good when I used it yesterday. Since I updated the Bridge plug-in this morning, it has also become like this and it can’t run. . .

I have already disabled the firewall on my computer. Then I turned off the antivirus completely. This problem has not gone away. :disappointed_relieved: :disappointed_relieved: :disappointed_relieved:

So I use BullGuard internet Security, and it looks like the firewall was stopping something called Node.js: Server-side JavaScript. this was being blocked, selecting Allow in the dropdown seam to be working. Capture

Hi guys!

Please write to support@quixel.com for assistance with this issue, along with any additional information you can provide so my support team can tackle this.

Hey Everybody. Not sure if this will help or not but I had another service running that uses Node.js for a server. Stopping that service worked for me.

1 Like

I am having the same problem, so I’m going to leave a post here to draw more attention to this problem, in the hopes that such attention will result in the development of a solution, or at the least, more information. I have tried disabling my VPN and Firewall, separately and simultaneously, to no avail. If I find something that works, I’ll post back here

Please write to support@quixel.com so one of my agents can assist you with this issue. Thank you!

JH
Quixel Community Support Lead

I managed to fix this issue for myself. TLDR: If you are using Windows 7, you need to set the following environment variable in windows and then restart unreal editor:
var name: NODE_SKIP_PLATFORM_CHECK
var value: 1

Long version:
I started by doing a process scan and I saw a epicwebhelper process starting and stopping everytime I attempted to open bridge. I look at its properties and I saw it trying to connect to a local port 5017. However, nothing was running on that port. I then did a dump of processes and noticed node-bifrost starting and stopping almost instantaneously. I then ran this executable directly and it informed me it cannot run on older versions of windows and if I want to force it, I need to set the above mentioned environment variable. After doing so, when I open bridge, node-bifrost starts and bridge opens fine. Hope this helps others!

3 Likes

I looked at my system and UE 4.27 wants me to download Node.js, which then meant I could no longer access as described above.
It upset my Quixel UE50EA as described
I “Uninstalled” Node.JS and now Quixel works again.

Here is my report to Quixel support @Jonathan.Holmes - support@quixel.com
See problem Quixel Bridge Failed to restart background service - Development Discussion / Unreal Engine 5 Early Access - Unreal Engine Forums

I looked at my system and UE 4.27 wants me to download Node.js, which then meant I could no longer access as described above in UE5EA

It upset my Quixel UE50EA as described above

I “Uninstalled” Node.JS and now Quixel works again.

What is really difficult to understand is the preferred option for Visual Studio

is to load Node.js package from the installer no the Web site.

http://nodejs.org/en/download which is different version from Visual Studio version

Why does this conflict with Quixel and can the node.js be configured to stop annoying network errors

In summary I don’t have any node.js package as I am not interested in 4.26/4.27 only UE5.0 EA

Thanks

Jimbo
The support ticket is

" Quixel Support Notice, re: Quixel integration for UE5EA breaks when Node.js package loaded for UE 4.27 - ticket #93684"

Thanks, we’ll be looking into this!

Is anyone with Win 10 experiencing this issue?
Looks like a compatibility issue with Win 7 OS that Bridge does not support anymore.

Thank you, it’s useful! :smiley:

I’m having the same problem. My son found this error. I’m running win 10 pro64bit. Maybe this will help in some way. Until then it looks like I will have to try to uninstall the plugin and reinstall without the update (which I installed today 10-11-21)
PS C:\Program Files\Epic Games\UE_5.0EA\Engine\Plugins\Bridge\ThirdParty\Win> .\node-bifrost.exe
Listening on: 5017
TypeError: Cannot read property ‘assetType’ of undefined
at C:\snapshot\node-bifrost\packages\bifrost-server\dist\utils\library.js
at Array.filter ()
at getLocalAssetsCounts (C:\snapshot\node-bifrost\packages\bifrost-server\dist\utils\library.js)
at C:\snapshot\node-bifrost\packages\bifrost-server\dist\utils\library.js
at C:\snapshot\node-bifrost\packages\bifrost-server\dist\utils\library.js
at C:\snapshot\node-bifrost\node_modules\graceful-fs\graceful-fs.js:69:14
at FSReqCallback.oncomplete (fs.js:180:23)
Uncaught exception occurred: TypeError: Cannot read property ‘assetType’ of undefined
at C:\snapshot\node-bifrost\packages\bifrost-server\dist\utils\library.js
at Array.filter ()
at getLocalAssetsCounts (C:\snapshot\node-bifrost\packages\bifrost-server\dist\utils\library.js)
at C:\snapshot\node-bifrost\packages\bifrost-server\dist\utils\library.js
at C:\snapshot\node-bifrost\packages\bifrost-server\dist\utils\library.js
at C:\snapshot\node-bifrost\node_modules\graceful-fs\graceful-fs.js:69:14
at FSReqCallback.oncomplete (fs.js:180:23)
Exit called