Quick settings add shaders to compile?

It does not add shaders, shaders have to be recompiled because its parameters are changed when you change settings.

For some reason answerhub ate my second part of the answer.

It looks like you had no shaders compiled before launching effects cave, and by every setting switch it adds corresponding shaders to the queue, it should not really endlessly increase amount of the shaders being compiled. I’ve never experienced this issue while switching settings. But yeah, actually sounds like a rare bug.

I expect this is a bug, anyway here goes.
Opened the Effects cave in 4.1 and it started to compile shaders, a total of ~3000, so while doing this I switched quick settings to lowest, that added another 2000-3000 shaders… okay, switched back to ‘epic’ (where it was originally). Guess what? It added another 3000 shaders. Everytime I switch it adds shaders.

To give an idea:

But why does it add shaders that should have been compiled the first time around? I mean it adds shaders to be compiled for “epic” settings twice. I mean I could potentially have it add up millions of shaders if I kept changing settings back and forth between two settings.

Well after restarting the computer I didn’t have to compile any more shaders. As you said, rare bug probably.

I’ve been having this problem as well. The editor starts compiling shaders as soon as i open a material. Then it adds shaders every time i tweak a value and doubles the amount when i hit apply. Eventually it is taking a whole lot of time until i see the end result. I’ve tried two different drivers just in case but nothing helped. I’m attaching the dxdiag, hope it helps.DxDiag

Hi everyone,

Can you please post your dxdiags here so we can have a look at what might be going on? Thank you!

Here you go:
link text

Thanks for the response but it seems what I had was some bug. I couldn’t recreate the incredibly long queue.

Hi everyone,

Our lead rendering programmer, posted a response on another thread. Here is what he said:

When we added support for async shader compiling it significantly reduced the amount of time the editor blocks when updating the preview material. It was a great workflow change for our artists but I can see how it would be frustrating on some hardware, especially CPUs without many cores.

We have made some changes for the next release to reduce the number of preview shaders we compile which will decrease the time it is taking. I hope that helps. I also appreciate the feedback, we’ll take it in to account and consider whether we should add an option for disabling live preview.


Hi everyone,

We have released a preview version of the 4.1.1 update. This contains a fix for the shader compile issue. You can find more information here: 4.1.1 hotfix update now available - Announcements - Epic Developer Community Forums

If you do not wish to try the preview version, we do expect to have an update for everyone within a week. Thank you and have a great day!