"Programs" and "Rules" in visual studio solution UE5.3

What is it exactly? It doesn’t exist in 5.2 version, when I generating vs project files.
I’m asking this, because Rider found a lot of errors in it, while everything keeps working and compiles. If someone knows how to fix these errors please answer.

Did you tried to change the engine version?



Rider work well for me

Why should i do that? I’ve created fresh new 5.3 project.
So I’m speaking of this:


While 5.2 project structure looks like this:


I think your engine folder is not loaded well… i think that is the reason you have those errors.


I have 1700 projects…

Try this… Do not open the project using the .sln file

Open YourProject.uproject with Rider directly

1 Like

Yeah, it works like that, and i have switched my Source Code Editor from Rider to Rider Uproject for compatibility. Thanks for that.
But other question still remains. What about Visual Studio? You need to work with .sln if you use it, and you will have these ‘Programs’ and ‘Rules’ from now on. What exactly are they and why 5.2 don’t have them?

I don’t know that… I’m not using visual studio. It is so so slow

Does everyone have these 2 extra folders and additional build actions when opening a 5.3 .sln file that weren’t present in other versions? To reproduce: Launch 5.3 through the Epic launcher. Create a new 3rd person c++ project. Open the .sln. I see the the Programs and Rules folders. Building queues up 40+ actions when I expect only 1.

Opening the uproject with Rider helps, but what’s going on with the engine folder not loading well? Additionally, building fresh brand-new 5.3 projects with either Rider or VS has 40+ actions compared to 1 action in previous versions. Initially, It wouldn’t build for me until I updated NuGet (see bellow if you have that issue) I don’t think it’s a 5.3 thing. I believe OP and I have done something wrong.

I’ve tried:
Uninstalling 5.3.
Deleting the AppData/unreal folder.
reinstalling 5.3
verifying VS installer
updating NuGet package source (Do this first if you’re having build failures)

5.3 builds were acting normal 2 days ago for me. I’m trying to think of things I’ve changed. I first noticed it when I move an older 5.3 project to a new folder, and I thought that broke that project, but it’s the same issue in new projects. There were 100’s of ‘error NU1102: Unable to find package’ until I updated NuGet. It builds now, but there’s extra stuff, 40+ actions, it’s building and those 2 extra folders. Additionally, I changed some VS settings as per UE docs. I changed Editor settings to Rider Uproject. All prior to me noticing the issue was more than that project I moved.

How to update NuGet / get the 40+ actions to build and not fail:

  1. Open Visual Studio (you can select Continue Without Code)
  2. Navigate to Tools > Options > NuGet Package Manager > Package Sources
  3. You’ll most likely see only one source titled “Microsoft Visual Studio Offline Packages”
  4. Click the “+” button to add a new source
  5. Name it whatever, and type “https://api.nuget.org/v3/index.json ” for the source
  6. Click the “Update” button and then make sure it’s checked

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.