Problem with lightmapping in UE4?

I am working to construct a modular tile set of various parts. However, what has been confusing me is that the lightmapping on this one particular tile does not seem correct within UE4 even though I set up the lightmap UVs beforehand in Blender. There is a dark segment at the center of the tile, only visible in lit mode. When I view the tile with no lighting everything is fine, so I imagine it’s an issue with the lightmap.

I have attached images of the issue I am experiencing.

Hi,

How did you create the door opening? Did you use booleans?
To me it seems as if your mesh topology is not sound.
Is it possible that where the edges of the dark rectangle are, some vertices are doubled, so edges only appear to be connected, while they arent?
Also check and make sure your mesh does not contain any Ngons. Strictly quad.

Cheers,
Klaus

Thanks for the response,

I checked to make sure that there were no doubled vertices by test-deleting the verts around the door. I also used the “Remove Doubles” and “Delete Loose” functions to make sure there was no extra geometry. As far as I can tell, there are no doubled verts or polygons.

In regards to the Ngons, I triangulated all the model faces and re-exported to UE4, and the dark rectangle still appears.

Hi,

Hmm. My next suggestion would be: Set the light to movable, thus making it fully dynamic.
If the artefact still appears, then its not a problem of static lightmap uvs, but something else.

Cheers,
Klaus

Have you already added a lightmass importance volume + increased the lightmap resolution? What happens when you add a skylight (with “cast shadows” disabled) into your level?

You’re using uv space extremely unefficient.
You have not used almost half of available space, in some way you’re downgrading 1024x1024 textures to 512x512 and way worse.

Elements in Lightmap UV should be scaled properly, currently your biggest object(wall) scaled into super small object. It’s not right at all and you should definitely fix your uv before using this mesh.

Wall element in your UV unwrap have ~160x128 pixels in 1024x1024 map.

Default Lightmap resolution is 32x32 pixels, so your biggest element(wall) is using ~5x4 pixels from lightmap texture.

Looks like possible shadow bleeding. As zeOrb said you need to scale your lightmap UV’s correctly. Also you need to make sure that you can align your shells to the grid so you prevent light bleeding as much as possible. If your texture size is 1024 x 1024 and your lightmap resolution is 32 x 32 go to your UV Texture Editor in Maya and change the grid size, divide 1 by 32 = 0.03125 <------ that is your grid size.

Because your lightmap resolution is 32 x 32 px you will need your grid size to 32 px size. This will allow you to have a 2 - 4 px padding between your UV shells for your lightmap. Lightmap UV layout is not like texture UV layout, you can’t have overlaps and there NEEDS to be padding otherwise you will get shadow/light bleed. Because your UV shells are so small that is why your getting that huge black space.

I really would recommend you read this to fix your problem.

http://www.worldofleveldesign.com/categories/udk/udk-lightmaps-02-uv-techniques-and-how-to-create-second-uv-channel-in-maya.php

And to add what others have said about the UVs, be sure to read this: Unwrapping UVs for Lightmaps | Unreal Engine Documentation