Download

Problem: Metal 1 = Total Black

Good day,
My door should be Metal0 and that plate on top ​Metal1, since it looks very different from the Substance viewport, I tried to mess with some metallic values. What happens makes no sense: Metallic1 equals Black in the viewport, a totally different result from the material editor.

](filedata/fetch?id=1874149&d=1616616735)

  • Diorama project
  • Sphere reflaction capture placed and built,
  • SkyLight Specified cubmap “EpicQuadPan…”
  • 8bit Png.
    -sRGB off on ARM Texture
    -Linear Color on ARM Texture
    -Adding a skysphere and/or a directional light doesn’t change anything

](filedata/fetch?id=1874154&d=1616618609)
](filedata/fetch?id=1874153&d=1616618818)

If the vewport has no reflection capture, no enviroment. And no built light. What exactly would you expect the metal to reflect?

Try setting your skylight to ‘movable’. That tripped me up last time I got stuck with this issue…

It has it and I wrote it, the Refl. probe is actually in every picture and it is built.

I tried, no luck, thanks for the tip man. I don’t understand what I miss from a blank scene to have a PBR metal working.
Plenty of stuff to reflect now, particulary from this angle, I thought the skymap lower emisphere color was the problem but it didn’t improve much changing it.

](filedata/fetch?id=1874241&d=1616654195)

](filedata/fetch?id=1874242&d=1616654202)

Even in the dark env. of the first person template it looks fine, in my project looks like unlit paint.

For one, there’s now too many point lights in the area. It’s actually surprising at least one of them doesn’t have a red X over it.

For 2. Since none of your screenshots include the whole view port we don’t know that light and reflection captures are actually built.
they sure don’t look it, the metal panel should be reflecting the blue hues even if black.

First check your material parameters. Make sure you have the right settings on default lit. Default lit, etc. See if you accidentally turned on or off any value you shouldn’t have.

Then Put a multiply x1 on the metal map and click the down arrow. shoot a screenshot for us (we can sort of tell what’s blue and what isn’t, but still).
Same for roughness just to double-check it (It seems like it is all set to 0 from the little image. Which is probably fine).

also, put a .5 static value in specular.
It’s the same as the default, so it shouldn’t change anything, but it’s good practice so you know visually you haven’t set it to something.

Last thing to check is removing the AO.

Still pretty sure your material is OK though. And your light building isn’t.

Thanks MostHost for your time,

Here what you asked, dunno why the multiply preview is red…it should be white right?
It should be a black scene with a black skysphere and no directional light in it, I just changed with a default BP_SkySphere to understand where we are wrong.
All the lights you saw are movable that’s why there wasn’t a red cross.

](filedata/fetch?id=1874288&d=1616669647)
](filedata/fetch?id=1874287&d=1616669647)
Here the blue channel looks fine:
](filedata/fetch?id=1874290&d=1616669647)
](filedata/fetch?id=1874289&d=1616669647)
Substance render
](filedata/fetch?id=1874291&d=1616670198)

It’s actually more odd than you thought because the light fixture seems metallic and it looks to be reflecting.

the material is fine.

You need to start looking at the mesh, the scene and the engine settings.

Is the panel set to static? does changing it to movable change?

Is the Material two sided? If so, could the normals be flipped?
(Then again mesh preview wouldn’t look right)

What are the reflection capture settings?

That’s about all I can thing think of on the fly

I was able to reproduce this on the same mesh in the first person shooter template by eliminating “everything” (BP_Sky_Sphere, Directional Light, Skylight, lights).
Only at the end I disabled the last reflection capture probe and it finally showed up like in my project.

I was thinking about this bug or similar: Unreal Engine Issues and Bug Tracker (UE-86172)

But it is hard to call for a bug as a relative noob that I am so tomorrow I’ll be testing around, maybe moving the probe in other positions or trying with some CVars if I find any that can be useful.

Peace

Let us know as you debug.

Also, You could potentially test a different engine version.
I think the forums would be dazzled with “what is this ■■■■” posts if metal’s were broken even just a little. But you really never know…

The Master Mat. I made has a wrong AO placeholder when a Subtance AO texture is not used/loaded in the relative Mat. Instance texture parameter:

-> This lead to the walls around the door to be pitch black (AO=0); I had movable lighting so the Walls material looked fine in the viewport but still affecting the reflection on the metal plate!

→ I changed all the direct/indirect light to static, I baked it and actually fixed the problem of the metal plate, but the walls instantly showed up their AO=0 becoming black

—> Now I just have to find a correct AO texture placeholder and remove that embarassing _AO switch.

At least I learnt something and I didn’t rage quit.
Thanks endlessly and sorry for the false alarm [USER=“3140864”]MostHost LA[/USER]

hey, at least you figured it out.
Nothing wrong with having a ton of switches in a master material btw.
Between those, texture parameters, and mask parameters, a half decent master material ends up being around 20 parameters or so.
And you usually expose more when you flip the switches.

Personally, I don’t use AO masks.
I wouldn’t say “ever” there are some situations when it’s definitely needed. However, it’s an extra texture sample, which as you found out does near nothing in dynamic light…

Yeah looks like switches are not a problem… definitely they provide a cleaner look with lots of param instead of using just placeholders. Cheers