Prevent Pawn From Moving with Base?

Hey, all. My problem is that my character is moving with a platform/base. For an example, let’s say I have a moving platform. I want the pawn to be able to move but while the platform moves from under him. Here’s an easy way to “reproduce” it:

  • Create a new actor with just a (horizontal) plane in it.
  • Place one
    of these new blueprints into the
    world, hovering a little bit above
    the ground.
  • In the Character
    blueprint, choose a key and when that
    key is pressed, have it find all
    actors of the plane actor class that
    we just created.
    Make a get node and
    get 0 in the array of returned
  • Drag off the get node and
    make a offset actor location node and
    hook the in exec up to the find all
    actors node’s out exec. For the
    offset amount, ~100 on X would
    probably be a good amount
  • Run the
    game and have the character stand on
    top of the plane. When you press the
    key you assigned to offset it, the
    offset location from the plane will
    be transferred to the character’s
    actor location.

Is there any way to disable this, so the plane simply slides out from underneath the character? I believe any other actor that isn’t a pawn simply does stay in the same spot and doesn’t maintain the teleport offset from the base they are on.

The character isn’t being “offset” because it got transferred from the “plane”. You ARE moving the “plane” the character happens to be on that plane and so moves like anything in real life would. To prevent that you would need your character to “hover” instead of be confined to the laws of physics and gravity. Or possibly play around with “friction” settings, perhaps 0 friction on the plane mesh will allow the character to “slip” off like the ground was made of ice.