Prevent Emissive Surfaces from being baked with GPULM?


GPU Lightmass in UE5 constantly treats emissive surfaces as light sources, and bakes them into my lightmaps. This was not the case in UE4 unless you tick “Emissive Light Source” on the static mesh.

I’ve disabled Lumen in my project and Post-Pro settings.
I’ve experimented with many variables on the static mesh, the emissive material itself, the GPU Lightmass settings, and some project settings, but to no avail.

I used GPULM extensively in UE4, and the ability to control the materials bloom, and place a light component that I can also control to emulate the light that WOULD come from the emissive surface is very desirable. It bakes better lightmaps anyway.

As fast as GPULM is, I believe a light component is cheaper to bake as well, which makes a big difference with a really busy scene with lots of emissive surfaces.

With characters in a scene, using light components instead of emissive surfaces gives WAY more control over the indirect lighting strength, which is huge for making sure the character appears right next to the environment.


CPU lightmaps do NOT bake the emissive surfaces as light sources, but as we know, its SO much slower…

Setting the static mesh to stationary, or to not cast shadows stops the emissive from being baked as a light source, but for static meshes that have a small areas of emission, they will not appear right in the environment.

“Emissive light source” is indeed unchecked, as it is by default.

Below is a simple cube I’ve been testing various tweaks with. I’m just shocked that UE5 lacks the ability to disregard a mesh with an emissive surface as a lightsource for GPU Lightmass.

GPU Lightmass is a phenomenal tool for baking very performant scenes with nice GI in relatively little time, and I’d really like to find a solution for this issue.

If all else fails, I will need to set the emissive values on the meshes to zero and insert separate emissive primitives with “cast shadow” disabled. It definitely makes more work for kitbashing environments though.

Let me know yalls thoughts, thanks.

Seme problem here … Did you find some solutions since your post ?

Okay, I found this solution by Editing material and add a “Lightmass replace” node for Emissive color.

Seems to work as expected for me to cancel emissive influence on GPU Lightmass lighting build.

There is a POC for example:

  • empty level
  • Static Plane
  • Static Point light
  • Static cube with the material above

Result WITHOUT “lightmass replace” node:

Result WITH 'lightmass replace" node:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.