Post Process Effect stop working

Somehow after getting project from my colleague, post process volume that he set it up has stop working. I also tried to create a new scene and add post process volume but it doesn’t work. Is there some setting that got messed up after getting the project?. I am using 4.5.1

Thanks,

Hi Shantaram,

The first thing I would look at would be the Engine Scalability settings to make sure that these are set to EPIC. If it is not the post processing will be disabled. This feature enables the editor to run on lower end PCs or if the CPU load is too much it can lower the settings in the editor to free that up some.

To check the status of the Engine Scalability settings go to your tool bar above the viewport > Settings > Engine Scalability > here set the option to EPIC.

Let me know if that works for you.

Tim

It is set to Epic and it still doesn’t work.

THanks,

Just wanted to add that its a perforce project so is there some file that needs to be checkout to make it work.

Thanks,

Post processing should be there if you have the editor and the project is loading up.

Can you try selecting the PPV and scroll to the bottom of the details panel and select “Unbound.” This will make it so that everything is affected by the volume and not just what’s inside it.

If that doesn’t work, let’s make sure this isn’t just project related by creating a new project. That is if you’ve not done this already.

My typical test for quickly checking post process:

  • Create New blank Project - no starter content or anything else required
  • Use the default level
  • Place a PPV and set it to unbound with Bloom and Lens Flare with intensity cranked to full
  • Adjust the camera and look at the Sun directional light

At this point you should have what looks like a J.J. Abrams movie going on. If not, there is something going on that may require a reinstall of the editor or something else that I’m not fully sure about at the moment.

If it is working, then at least we know it’s something with the project that we can take a look more closely and try to determine what is causing the issue. :slight_smile:

Let me know.

Tim

I did tried those steps and it is something with the particular project that I am working on. It is working on the other projects.

Thanks,

Hmm…That’s strange. :confused:

If you create a new level in this project are you able to get PPV to work properly? I guess then we can narrow it down to that individual level.

If you’re able to narrow it down to that level would you mind sharing that map file? It won’t contain all your other content, but maybe there is something corrupted with it that I can at least try and figure out a workaround for you.

Thanks for help, I really appreciate it. It doesn’t work in the new level that I create also.
How do you I share the map? Should I just upload the map file here or do I have to migrate or export it?

Thanks

You can upload the map here is you’d like in a zip file (as long as it’s below 5.2 mb), if it’s above that you’ll need to use a link for a shared cloud drive like Google Drive, DropBox, or OneDrive.

If you don’t want to post it here you can always send it privately via a PM to me on the Forum via this link: https://forums.unrealengine.com/private.php?do=newpm&u=4894

As far as the content. If you migrate the map it will grab any material or assets associated with that map to send as well. If you’re comfortable with that that is fine. Alternatively, you can just grab the map file in question from the projects folder and just send the MapInQuestion.umap file.

link text

Its just a blank scene with post process volume set to unbound and tint color change to red.

Thanks,

I’ve had a look at the map, and everything the post process is definitely made it a bright red scene.

So, this map isn’t producing this on your end? Just to be clear.

Nope. Its not working on my side.

Thanks,

Which version of the engine are you currently using?

4.5.1 and I also tried to upgrade the project to 4.6 and still it didn’t work.

THanks

Since we know it will work in a new project, but is not with this this current project, I’m kind of running out of ideas without migrating all content to a new project. :confused:

Can you open up the project folder and try deleting the saved and intermediate folders (I understand there may have been changes made to these, but just as a test). You can just move these out of the project folder to back them up if needed. The editor will create new ones when you start the project back up.

Let me know if that has any effect with the scene.

I tried that already and it didn’t work.
I already created new project and migrated all my content and its working perfectly.
As we created a whole new project, I can delete content from my old project and share the whole project with you so that you guys can look into in more detail.
Would you mind if I share that project?

Thanks for all the help

That would be absolutely fine. I’d definitely be interested in trying to get this to happen on my end or at least see if there is anyway to reproduce what happened.

You can post the link here or send to me on the forums and I can check it out.

I have PM you the project link on forums.

Thanks,

Hey,

i’ve got the same problem. Are there any new informations about how to fix the bug?

Best regards,
Pighty.

Hi PightyMo,

Did you read through any of the information below, If so, did you try any of the steps below as well, as this would be my troubleshooting process.

Can you post a copy of your DxDiag? This was something I didn’t ask Shantaram though, if willing I’d be curious with that one as well.

There may be a correlation here that I could have our Compatibility team look into. With the test maps and images provided I was not able to reproduce the error on my end.

Shantaram provided a test project that this is happening with as well. I’ve got time to start looking into this one a little more this week, and since opening it I can see the test project it is not functioning properly. I have no idea why at the moment and will need to investigate further.

If you have any way of recreating the issue in a more consistent basis I’m definitely interested or even just clues to what happened right before it stopped working.

Right now, the work around seems to be to migrate content to a new project. Not the best solution at the moment though.