Poor shadow quality with correct size lighmaps

Hi everyone!

I’m quite new to the engine, so I’m probably missing something easy. Hopefully you’ll be able to guide me to a solution.

Problem: I’m trying to light a low-poly cave with simple torches. However, there’s no way I can get it right.
The static mesh that creates the cave is split in several parts, each with a 1024 px resolution lightmap. This resolution should work fine, as I have similar sized meshes on the outside with 512 px lightmaps that work just fine. Moreover, when I use the lightmap density viewmode, everything has a good light blue/green color, so I suppose that’s ok.
The point lights placed on the torches are set to stationary and you can find their settings in the screenshots below.
As you can see in the image provided, the shadows look good when close to the light source, but then rapidly become horrible. Maybe it’s some kind of problem with indirect lighting? I have no clue.

Any kind of insight is extremely appreciated. Thank you in advance to anyone willing to help!

What kind of result do you want to reach ? If you cloud clarify “…but then rapidly become horrible”.

The shadows become blotchy and really ugly, as showed in the image below the red X. I think Unreal can generate far better shadows in low light environments, am I wrong?

You may try to set up Ambient Occlusion and put some lights with low intensity then play with cold colors like blue.


If you are experiencing this problem, try tweaking the Lightmass Settings in your World Settings. After some trial and error, I found that increasing the Num Indirect Lighting and the Indirect Lighting Quality and Smoothness helps a lot, but it will increase a lot your build times, so be careful!