Download

Point light issue - half cut away

Hello there,

I have an issue with lights, very simply, from time to time when I close and re-open the editor, point lights are cut in half, please see picture bellow:

What is the source of this issue? The light build quality is set to production at those picture…

Thank you for any information.

BR,

K.

Looks like you have too many point lights overlapping. The maximum for dynamic is 4 I believe (?).

Try changing them to static or lower the attenuation radius so they no longer overlap, then build your lighting.

Yep that might be because the lights are too close to one another and have overlapping radii (can cause issues when baking the lightmaps). That shouldn’t happen with dynamic lights.

I assume they are not movable?

You might want to try out making them movable which makes them fully dynamic - this might solve your issue. Just keep in mind: Movable lights are computationally very expensive and should be used only when really required.

Cheers,
Michael

Hmm. To me this looks like incorrect normal map range more than a shadow issue. You get light like that if you import a normal map as a regular texture instead of a normal map because the surface thinks flat has a vector of 0.5 instead of 0. But it is very odd this bug is showing up on the default material. Have you edited that material at all? Have you changed compression settings for any of the textures in engine?

If not then I suppose try saving a copy of your scene with one 1 or 2 lights and see if you can reproduce the issue.

It is also very possible this is a driver bug caused by your video card. What card do you have? Do you have the latest drivers? Could also be something like bad shader cache maybe. Seen stranger things be driver specific.

1 Like

Hi again,

I did some testings and I found out that this issue happends when I enable “Use DXT5 Normal Maps” in project options:

It happends even at newly created level.

Can it be a bug?

Thank you a lot for your hints. I will keep this unchecked for now.

K.