Point light fading

Whenever I walk towards a point light in my level it randomly dims, giving off no light at all.

The lights work at a distance, but not when near them.

The lights were not doing this in 4.6, but started doing this once I upgraded to 4.7.

Hello Pinchiinator13,

Thank you for your post. I am looking into replicating your issue, but I am having a little bit of trouble. I have a few questions that I would like to ask that will help narrow down some of the possibilties.

  1. Are you on the newest version of 4.7 (4.7.2)
  2. Does this behavior occur in a new blank project?
  3. If you are able could you include some screenshots of what you are seeing along with any settings that may have been changed?

Once I have this information I should be able to determine if we have a bug on our hands and then hopefully get your issue worked out.

Thanks in advance,

Benjamin Hyder

1.) I am using 4.7 (4.7.2)

2.) Behavior does not occur in a blank project. I tossed a point light in a project, tested, this did not happen. Built lighting, tested, did not happen.

3.) Ignoring the door, in the first screenshot you can see the lights working as intended. Upon moving near them, they completely disappear, as seen in the second screenshot. As far as settings go, I changed the light intensity, light color, attenuation radius, and cast shadows on the light in the hallway.

This project was originally started in 4.4 I believe, then transferred to 4.6, and now 4.7. In 4.6 this problem was not occurring.

Hello Pinchinator13,

I set up a test area similar to what you have pictured. I also modified my lighting setting to try and replicate the issue. When I set my scene up, I could see the lights, when I was at the far end of the hallway (with the door) however, as I approached the window the lights became overpowered by the ambient light that was coming through the window. This causes the eye adaptation to take effect, which increases the effect. Is this what you are experiencing as well?

Thanks in advance,

Benjamin Hyder

From what you describe that sounds about right. Is there any way I can change the eye adaptation?

Hi Pinchinator13,

You can change and/or turn off the eye adaptation. Select the global post process volume from the world outliner, then in the Details panel under “Auto Exposure” set the values for “Min Brightness” and Max Brightness" to the same thing. (I like to start with .5 and move up and down from there until I get it the way I like it.) As long as both Min and Max are set to the same amount it will disable the Eye Adaptation and lock the exposure at the value that you have chosen.(higher values will make the image darker, while lower values will make the image lighter. If you have any other questions just let me know and I will be happy to help.


Benjamin Hyder

Looks like that worked! Thank you greatly for the help!

No problem at all Pinchinator13. Glad that I could help you work out the issue. Enjoy the editor!!