Point Light bad light problems lines without light

This problem is in the 4.8 / 4.9 / 4.10 preview and idk if in other too.

A. Create a new project or use one with a medium or big map (with large meshes). (I’m using the vehicle template project)
B. Place a pointlight in the map near to the ground and set as stationary or as movable.
C. In the light uncheck the bool User Inverse Squared Falloff and attenuation radius to max 16384.0 and set a some visible color.

Now as you can see will have the same problem of me:


I get many problems with this in the mega jam with the cave. The Purple Essence - Cinematic Complete - YouTube

Hey Hevedy,

In order to narrow down what is causing this I would like a little more information from you.

1.) Can you link me your DxDiag?
2.) Have you built lighting and is it set to production?
3.) What are you engine scalability settings? Are they set to Epic?
4.) What is the lightmap resolution of your objects?

After I gather this information I can start to narrow down what is causing these lines.

  1. https://dl.dropboxusercontent.com/u/28070491/UE/Forums/DxDiag.txt
  2. Is realtime
  3. Yes
  4. Idk the default of the project is realtime so no lightmaps

So what you are seeing is expected using the workflow that you have. If you have a static or stationary light inside of your scene you will need to execute a lighting build. What this does is calculate the light bounces of a light and determines where the light is influencing an area. This is done for lights that are not being calculated in real time. Only movable lights are calculated in real time as they are, as their name suggests, able to move throughout your scene.

I did a little testing and this is the result.

This is the result after going to, in your viewport, Build > Lighting Quality(Set to Production> Then go to build lighting only.

With movable there are some gotchas. Now you are calculating your light in real time where these raytraces are updating every second. This allows for more accurate calculations but also more expensive ones. If you switch between static/stationary/movable you will need to rebuild lighting again just to make sure that the previous calculations are then not present in your scene.

This is the result of changing to movable. I deleted all of the other lights to make sure there were no other influences in the scene. Save before doing this next part. Going to project settings > Rendering > Generate Mesh Distance Fields. This allows for calculations of light and shadow as well as geometry to be calculated by distance from a light source. After enabling this and restarting your project go to your lights details. Go down to RayTraced DistanceField Shadows. This enables RayTracing(LightBounces) to occur based off of distance from light and camera. This is the result.

Here is another user that experienced the same issue. Without using RayTraced DistanceFields you would need to adjust your shadow bias. The effect will definitely increase the further the falloff and attenuation radius of the light is. What you are doing in this situation is calculating the lights falloff exponentially.

Link to documentation describing Inverse Square Falloff:

Although you will see the jagged lines initially this is intended behavior until the proper adjustments have been made with your light.

Sorry but this don’t fix my problem i’m talking about realtime light no about baked one.

If you read the description above the last picture it touches on just that. That light is movable and is using real time lighting.

I don’t like to use the Ray traced because need DX11.

After set 2.0 and 2.0 looks like give good results more or less thanks.

Yo! What about if we can’t use raytracing? I have the same problem with movable point lights

Any solution? I did`t experience this before. One detail is worth mentioning, that my disk storage space is almost full. Could this be a cause?